Pixhawk 2.1 gyro and compass problem

Just to chime in as well, I have had compass issues with my pixhawk 2.1 since I got it with 3.4 and the newest firmware. I have tried 3 compasses, the 3dr GPS/Mag combo and two internal and none of them seem to agree. If I look at the mission planner graph i can see mx,my,mz, mx2, my2…etc never agree. Tried all sorts of rotations, on board calibration, qgroundcontrol, calibrating in the middle of nowere, etc. In the end I disabled both internal compasses and am only using the external compass (3dr GPS/Mag). I get EKF compass spikes constantly even when it is stationary but I havent had an issue. @proficnc if you have any ideas I am all ears. Still loving my pixhawk 2. I have plently of logs. If you would like I can send you a google drive link to some of them.

Thanks for all your hard work you and the team have done!

Please send a photo of your setup?

Exactly same issue, gps is Here ProfiCNC … stable in stabilize mode and alt hold if i switch in loiter… very quick and random drift !!!

Try to erase config and redo compass calibration… totaly impossible if Here gps is connected …

Arghhhh it unacceptable … i want back with my pix 1 !!!

What is really difficult here… is that I am seeing complaints, but none of you are sending data…

Logs, photos, descriptions…

If there is a real issue, we will fix it! But so far, the only log shown has an aircraft that is set up totally wrong.

A few tips…

Use latest mission planner beta…
Use 3.5 firmware
Do onboard compass calibration.
Use external Compass.
Ensure AHRS and compass orientation are all correctly set up for your frame type.

If you add a new external compass after an existing setup, start again with calibration


How to get Mission Planner beta ?

@proficnc as a lot of us appreciate all the hard work yourself and the dev’s have put in , we are spending a lot of time trying to solve these issues ourselves, rather than just complain, so we can also help with the solutions for the community.

I, for one, am currently battling a processor hang on the Pixhawk while doing an onboard compass calibration, and have had to resort to the ‘old’ method.
This is also while trying to nail the cause of a couple of other problems, such as fly aways in GPS modes, SBF GPS problems in auto modes, compass errors all over the place, etc.

This has come about because we are adding so much more to each build, in particular this one, which has Laser Rangefinder, ADS-B, Septentrio RTK GPS, latest RFD radios, and so on.

I am looking forward to when I can send you some definitive data, as I am sure others are too.
But it takes time.

1 Like

Update to 3.5 Beta version firmware fixed my problem. Thanks a lot. ! Everything is running perfect now.

1 Like

The key though, is seperating out what is a hardware issue, and what could be setup or genuine software issues.

If it’s hardware, then I can help
If it’s software, then it’s an Ardupilot question
If it’s setup, then maybe the wiki needs improvement to make setup simpler…

But without the basic information about your systems, we can’t even determine that. So we end up with a thread that is filled with people saying “mine does that too”

That turns toxic really fast… as no one can offer real advice on how to fix the issue…

If there are hardware issues, I want to get to the bottom of the issues really fast… I’m heading to TW today to supervise the next batch… if there is an issue… now would be the time…

So pump the info! We want to help! But if people refuse to post logs, pictures, videos etc, then it’s just bad news for everyone with no cure.

@mboland, you have been around for a while and know your stuff, so I’m not trying to tell you how it is, but many others haven’t been.



On my last flight trial, I suddenly got erratic Bad Gyro Health messages.
For information, I never took off because of the wind and these messages.
I attach the log files for your investigation.

Kind regards,

2017-04-10 17-48-37.bin (1.2 MB)

2017-04-10 17-48-37.log (2.6 MB)

Bad Gyro is a useful message, but it’s a little lacking in what it means.

The initial Gyro calibration happens straight after poweron, before the system warms up…

So try powering on, letting it warm up a bit, then repowering

Read through some of these post as I’m experiencing the same type of issues. So I though I’d go through each issue separately.

Compass calibration would keep failing (using the new internal calibration process). Selected a more relaxed setting with allowed the second on board compass to complete (doesn’t think there’s a third). But once calibrated I would get constant inconsistent compass messages. Turn the second internal compass off which got rid of the messages.

Bad gyro health keeps popping up, but eventually clears. I’ll try the recommended reconnect after it warm up. Also getting inconsistent accels messages on boot, but they clear as well. Redone accel calibration numerous times with no change.

Err: EKF_CHECK-0 and ERR: EKF_CHECK-02 keep popping up. Nothing happens flight wise so far. I’ve read a few other post where this ended in a crash which is concerning. I’ve attached a bin file of those errors. Proficnc requested build info so attached is a photo of the rig with the following specs:
-frame, Hover 1
-motors, TMotor 3805 380kv
-esc’s, Castle Creations DMR 30/40
-props, TMotor 15" folding
-gps/mag, Here
-battery, 6s9ah Panasonic LiIon
-AUW 2.9kg

I bough a bunch of these to replace out old Pix

2017-04-13 15-16-25.bin (2.5 MB)
hawk and Pixhack AP’s, but thought I’d shake everything out on a this 3kg
small quad first. I’m holding off on the 17kg X8 carrying a Phoenix LIDAR util everything’s happy : )

Just starting to get bad gyro health during flights. Same unit as in the previous post. Message appears near the end of the flight when switching into Pos Hold mode. Nothing crazy happened, just the message. Hoping Proficnc can figure this out. Guess I can swap for another cube… Too bad the mounting screws weren’t on the top of the cube, that would make swapping so much easier : )2017-04-19 12-46-44.bin (4.0 MB)

X1Aero…did you check your vibrations?I am saying this because i read around that people have troubles with this new type of T-motor props(27" looks ok but people complain about 15 and 18")

I also got the Bad Gyro Health + Compass calibration issue yesterday and couldn’t solve it right away. So as far as I read the other posts here, the course of action would be:

  1. Update MP and Firmware (latest 3.5 Beta) / Reflash
  2. Redo calibration,
  3. Wait for IMU to heat up, then re-connect (if that solves it, is there a more permanent solution? E.g. delaying the gyro calibration on bootup?)
  4. Label compass 2 as external, turn by 180°
  5. Disable some internal compasses
  6. If all above fails, upload logs here and hope for @proficnc to do some magic?

Am I missing anything?

I’m very glad this community exists and people are so helpful. Surely we’ll get to the bottom of this so the next batch of PH2.1 or AC3.5 won’t have this issue. Hang on in there!


After flashing Rover, then Copter (Beta), I was able to do the calibration. MP kept telling me “3D calibration required”, but I just kept going anyways. So I checked in which order I have to calibrate the axis and did it blindly. Now I don’t get “Bad Gyro Health” anymore.

Compass Calibration worked, but Compass 3 didn’t show at all.

Are you using the Beta Mission Planner?

1 Like

Yes, I am. I got the Bad Gyro Health error again, yesterday, also the compass calibration. It cleared after a while though, so I’ll see if I can fly this weekend.

Low IMU temperature can’t be the cause (error showed with cold and warm IMU, then after a couple hours I reconnected -> cold IMU < and it didn’t show up.

I’ll post an update this weekend.

I was able to get the calibration working again but I had to re-flash the pix 2.1

All the compass values are going green but still getting a bad compass health message

Had to velcro the Hero+ to the cube to get decent results. will keep calibrating to see if I can get some set of values which don’t generate the bad health message

I was able to reso;ve the processor hang by reflashing the pix 2.1

Please mount it correctly in the airframe before doing your calibration

I am using 2 external M8N GPS that have built in compasses. Internal compass disabled. I did this because of the interference within the airframe where the Pix is located. Configured Pixhawk to use best GPS.

This is on a DJI S1000 frame.

No problems