Pixhawk 2.1 Elevon Servo acting erratic

After pushing the safety switch my left Elevon Servo is constantly moving it was locking hard over switched to Opti ESC and separate Bec now it just sits thier and agitates but right wing is fine and if I switch wires the problem moves to other wing
LOG FILE & Param

What Telemetry is on this vehicle?
What firmware?
How did you load parameters?

Ok… looks like you copied your parameter file from your old controller directly to your new one…

Please do the following.

Please reset your parameters to defaults. The most simple way of doing this is to load copter onto it, then load up plane 3.8

With your parameter file, identify ONLY the parameters you need for your specific frame.

DO NOT change any other parameters.

X-ROCK 915mhz usinmg Mavlinmk same one I was using on my pixhawk 1

Currently 3.8 beta 5 also tried 3.7

First time went from scratch firmware update,radio calb, 5 axis set, calb level,Compass calb, set elevens to 2.
Started with new YEP 60a ESC was getting 6v FROM ESC when pushed hardware safety switch left eleven went hard down elevon right eleven moving back and forth
unplugged it double checked all connections checked servos with servo tester. tried again that’s when left elevon that was locking burt up and started smoking and Burt up.
Replaced servo with new one tested with servo tester.
thought maybe YEP ESC maybe incompatible with with pixhawk went back to original Jeti Advanced Opti ESC
Installed 3 Amp Bec to power Servo Rail Verified 5V
Still safe issue tried switching elevens just Revered the problem
Checked all screws on pixhawk 2 cube to make sure they were tight.
ALSO noticed that the pitch and roll sensitivity is hyper sensitive
tried disconnecting telemetry,OSD,and ESC same issue running off bec
Tried using 4.8 V Nicad Battery safe issue
set my old pixhawk up just sitting on top of 2.1 servos acted OK
tried importing settings from old pixhawk using compare using only servo settings
I’m at a loss of where to go from here

Problem Solved
Pixhawk 2.1 must not like my Digital metal gear Servos https://1drv.ms/b/s!AuFirwug-g8_jPcNvQzSEd2sn8v3GQ


Keep in Mind These servos were in my plane with regular Pixhawk 2.4.8 with 50 plus hrs of flight time I considered them a known good and they operate perfectly with Servo tester

here is a link to the Servos in Question

Pixhawk 2.1
Step by Step Attempt to fix elevons

  1. Load Copter Firmware
  2. Load Plane 3.8 Beta5
  3. Change AHRS to 6 for 270 Pixhawk mounted Sideways
  4. Accelerometer Calibration
  5. Calibrate level
  6. Calibrate Compass
  7. Calibrated Radio
  8. Changed Flight Modes
  9. Updated Fail Safe Info
  10. Manuauly setup elevon option 2
    Tested Problem Still existed pulled out a Old set of Servos.
    Problem Solved for What ever Reason Pixhawk 2.1 Dos not like Hobby King HK-15148B Digital metal gear Servos

Yes I did but not until after Several attempts of clean firmware update and setup It gets to the point were you have to try something new rather going in circles.

I do want to take a Second to thank you for replying because I had all but given up :slight_smile:

1 Like