Servers by jDrones

PID tuning of a heavier 10kg quadcopter


(Severin Leuenberger) #1

Hello Dev Team

I have to PID-Tune a new 10kg heavy quadcopter. I think i will get better results with manual PID tuning, as I did on a lighter frame last time.

If I go for a 10kg quad, can I start with the standard pids of ardu copter 3.4.6?


Or should i lower the values first?
Does anyone have recent experience with doing the same on a heavier quad recently?

Best wishes, Severin


(Andre-K) #2

There is no simple answer to such question.
PIDs are not related to weight alone.


(Justin R) #3

I’m currently flying a 10Kg X8. I started with the default PIDs but set ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT to 10Hz.

The X8 flew OK with this setup, and I then ran an Autotune which has given me some very stable PID settings.

I would follow the recommended autotune method from the copter documentation. (http://ardupilot.org/copter/docs/autotune.html)

There are a couple of settings in there specifically for larger copters, so ensure you read the whole page including the ‘Additional Notes’ section.

Once you’ve done this and have a good tune, you can of course make small changes to the PIDs to your liking.

Justin


(Severin Leuenberger) #4

I was flying my 10kg copter today with the standard PIDs as they come after having flashed the copter on 3.4.6 (on a new flight-controller). That was not working to bad in stabilized mode. But the Inputs from my rc-controll where doing a much to intense steering signal. So the copter is by default set to a max tilt rate of 45°. When I do move the roll stick for 1/4 of its way to right, the copter goes to a full 45° Roll movement. How can I correct this?
@juzzle1 What does ATC_RAT_PIT_FILT help? I fount the following information “For large copters (with props at least 13inch or 33cm diameter) set the Rate Roll and Pitch filters to 10hz (in Copter-3.3 these are RATE_RLL_FILT_HZ and RATE_PIT_FILT_HZ, in Copter-3.4 they are ATC_RAT_RLL_FILT, ATC_RAT_PIT_FILT)”, but I dont know what it regulates!


(Justin R) #5

Do you have expo configured on your RC transmitter?

I use an FrSky Taranis and generally use ~40% Expo on Roll and Pitch, and ~20% on yaw.
This makes the control much smoother.

As far as I know, ATC_RAT_PIT_FILT and ATC_RAT_RLL_FILT control low-pass filters on the rate controllers. Someone more knowledgeable may be able to explain further.


(Justin R) #6

Maybe @Leonardthall would be kind enough to explain what ATC_RAT_PIT_FILT and ATC_RAT_RLL_FILT actually do?


(Leonard Hall) #7

Hi Juzzle,

They are the D term filters for Pitch and Roll. They ensure that the D term doesn’t become too noisy.


(Justin R) #8

Thanks @Leonardthall


(Severin Leuenberger) #9

I did the ATC_RAT_PIT_FILT and RLL_FILT to 10 Hz, did reduce the RC_Feel and performed AutoTune on Roll, Pitch and Yaw. The result is astonishing. After attaching a new Battery, i recognized some jitter, and I think I will reduce Rate_P on Roll and Pitch some ticks.
On Yaw, I still have bigger problems, when I do quicker Yaw-Movements (more tan 90° per second), the copter does significantly loose height.
Maybe I can correct this with POS_Z_P?
I think thats this value here?


Those are my new autotuned parameters by the way.

@Leonardthall could it be that a reduce on FILT Rate Yaw could help?


(Leonard Hall) #10

If you are losing height in Altitude Hold when doing a yaw then your aircraft is using too much power on your yaw and not leaving enough to maintain height. You need to back off the aggressiveness of your yaw command.
Drop your ATC_ACCEL_Y_MAX by 50% and drop ACRO_YAW_P to 3. What are those two parameters set to at the moment?

If you find your tune is a bit twitchy then drop your AUTOTUNE_AGGR to 0.05 and do Autotune again. Make sure you save your old parameters first.


(Severin Leuenberger) #11

I was flying ATC_RAT_PIT_FILT and RLL_FILT to 10 Hz for several month now for a 11kg Quad. Under normal conditions it works great. But under heavy gusts, the PID seams to be too sluggish. The copter seems to have to less response and does wobble.

How about setting the %_FILT to a higher rate like 15 Hz? Could this make the copter more responsive and having a more precise regulation on Pitch and Roll?

(by the way, I have upgraded to 3.5.3 in the meantime).


(Severin Leuenberger) #12

Or would be a new autotune with AUTOTUNE_AGGR,0.09 instead of 0.06 maybe resolve better my problem than increase _FILT Hz Rate?


(Leonard Hall) #13

So there are a couple of things I tend to try.

  1. Do Autotune with the AGGR set to 0.1.
  2. Check noise levels with IMU_GYRO_FILT set to 40 and the ATT_ roll/pit _D_FILT set to 20 and an autotune with AGGR set to 0.1

If 1 works then you are fine. If not, try 2.

Keep your Angle_P for roll and pitch below 10.


(Severin Leuenberger) #14

Hello Leonard
Thank you! I will try that.
Regarding “Keep your Angle_P for roll and pitch below 10.” - do you mean ATC_ANG_RLL_P and ATC_ANG_PIT_P?

My values now are the following:


(Leonard Hall) #15

Yes, those are the ones.

Let me know how you go.


Tuning a 10kg frame with 29 inch props
(Leonard Hall) #16

That tune looks much less aggressive than the one earlier. If you have not changed anything then I suspect that tune did not go as well as it could have.


(Severin Leuenberger) #17

The PIDs above are the ones I will go for a tuning flight tomorrow. The ones I posted earlier are from another copter. What if the ACT_ANG_ %_P values will rise above 10? Should I increase the HZ-Rate from 10 to maybe 12 or 15?


(Leonard Hall) #18

No, just drop it back to 8 or 10.


(Severin Leuenberger) #19

I just tuned Now. Those values rises up to 15 and 18. What are those values god for? Why ca I reduce after autotune to 10 without any risk?


(Leonard Hall) #20

Yes, drop them to 10. Autotune can go a bit high. I have a fix but have not had time to implement it yet.