PID tuning and overshoot fix

Hello ,

hope you are doing well.
I am having trouble with my quad .

Frame : TBS discovery
Motors: SunnySky 980Kv
Lipo: 3S 6000mAh

I am trying to tune my quad for the best performance but i dont seem to get it right .
Attached here is my log for the last flight , it seems to have some overshoots on Yaw, Pitch , Roll .

Is there any way to fix this overshoots in order that the quad goes to the position nice and smooth , without oscillation .

These are my best suitable PID values so fare .

attached you will find some picture of the overshoot .

Stay safe!

Kind Regards
Enerik

Latest Params.param (14.3 KB)



With some motors being commanded to max there is no headroom left for pitch/roll under high demand. Do you have a log of some less aggressive flying? Why not udate to current stable Arducopter?

Hello @dkemxr

Yeah i admit :laughing: , i was flying on altitude hold .
What version do you recomend ?

4.0.3 is current stable. Also, review the tuning guidlines here:
https://ardupilot.org/copter/docs/tuning-process-instructions.html

That size craft on 3S will be farily close to default for some of these parameters but some you have not set. 4S power would do you a world of good if the components can handle it.

Hey @dkemxr,

Thank you for your help , i just finished flashing the latest version 4.0.3 and doing the calibrations .
I will let you know as soon as i do the first flight test . Until know everything looks very good.

By the way my current set up is made for 3-4S battery . I might change the battery at some point in the future .
I will let you know the result .

Cheers
Enerik

Hi Enerik-Now that you are at 4.0.3 check out the Dynamic Notch Filter feature. On many craft this will allow a tighter tune and the process to set the parameters is not that big a deal.

https://ardupilot.org/copter/docs/common-imu-notch-filtering.html

Hello @dkemxr,

i did 3 flights using the AC 4.0.3 it flies well .
However i am still having alot of overshoots .

attached are some examples. It looks like i am having some vibrations also . Z axis is the most problematic .

I will try the Dynamic Notch Filter to see if it can help with the problem .
attached are some examples including my latest log also my params (17.9 KB) file .

Cheers
Enerik




I wouldn’t call that a"lot" of overshoot given the flight circumstances and Vibes should be tested at Hover not fast flight. Nowhere in that log is there an instance to determine basic vibe levels. And as before you are flying too aggressively for this craft as it’s configured. A firmware revision will not help this and neither will a notch filter.

Why don’t you hover in place in Stabilize and give it full stick both directions rapidly in roll and pitch, then look at Des vs actual. Then hover in AltHold for a minute so to collect usable Vibe data.

Also, you didn’t set some of the basic tuning parameters.

Hey @dkemxr,

this was my error , thank you so much .
I did change the following :

MOT_BAT_VOLT_MAX
MOT_BAT_VOLT_MIN
MOT_THST_EXPO
MOT_SPIN_ARM

These parameters helped alot in the motors thrust curve.

After that i did an Auto Tune and guess what? The copter was flying great .
So great in fact that i forget to watch the battery go draining hahaha . Fortunately it was near the ground when the copter started losing thrust . It landed safely .

I am attaching my parameters AC 4.0.3 (17.9 KB) and my Auto tune log file if someone has the same problem as me , setting the right tuning parameters before performing an auto tune is essential to get nice results .

i am still having some minor problem with yaw but still i am pretty happy with the results .



thank you for the help!

Kind Regards
Enerik