Overpowered hexacopter?

From some time I’m working on my old Hexacopter tali h500 from Walkera. It flies quite good on stock Ardupilot hardware but it was quite old with Atmega2560 so I upgraded it with Pixhawk 2.4.6.
I added second GPS, power board for reading voltage and current (6S battery). Also I power it from original PDB using Zener diode for some redundancy. It has two compases (built in and second on external GPS). GPS 1 and 2 works well with blending settings. I also add telemetry 433mhz, miniOSD for camera, and last thing is TFmini lidar for front obstacle avoidance. I leave stock battery (6S 5200mAh) and ESC with motors (cant find exact specs for it :frowning: 35 something with 500kV) and stock 9445 props. I leave stock ppm receiver with Devo 10 transmitter.
On stock FC it hoovers about 50% throttle and on Pixhawk it hoovers in less than 30%. Overall weight seem to be simmilar or even little more than stock 2550grams total. Is there any parameter to set better throttle settings? Or instead I could rise weight to make it heavier. I checked log after test flight in loitier mode and hoover throttle seems to be less than 20%.
It looks like motors are overpowered somehow but with stock FC all was fine so don’t have idea what changed and where that addional power comes from. In hoover it takes about 18A so it’s quite low I think.
Any ideas what to check?

You need to post some log files in order to evaluate it.

Are you stating it based on your throttle stick position? Because thrust output of your motors shouldn’t change between FCs, if your motors are “overkill” to your craft, they will be regardless all the avionics you install in it (assuming similar ToWs).

If you are stating it just based on your throttle stick, maybe you should review your radio calibration and double check if you do not have any trims in your radio. In Loiter mode you should hover always at mid-stick as soon this stick controls climb/descent rates.

Here are logs from that test flights.
I checked throttle trims on transmitter and all was centered. Transmitter was set properly for APM and hoovers about 50% throttle. Now on Pixhawk is about 20%. I didn’t change anything there so should be ok. Receiver is same too.
I checked in Mission Planner and radio calibration looks fine for me. Stick in the middle is about half of travel distance so I think is ok.

I should add… if I start in Loitier mode… stick is centered for hoover. Only in Stabilize mode it works in low range (up to 30%) so changeing to Loitier in flight could be really problematic becouse it really fast ascend with 50%… and if I change to Loitier with 25% it goes down so I have to fast add that missing 25%.

Could it be that mot_thst_hover learn was enabled on these recent flight and it was not on the previous ones? Also it never hurts to recalibrate your radio I recently had a constant uncommanded yaw that was the result of an uncalibrated radio.

As I know Mot_thst_hover was set previously to 0,32 afrer first tests. Before second I change it to 0,4 and after second test it changed to something around 0,2 or even less. I read it works in Loitier and AltHold modes, and there I have throttle in the middle and all works as it should. But in Stabilize… I can’t reach more than 30% throttle or drone will ascend like crazy.
Weight is almost same like stock one (about 2500g before and now 2550) with gimball, camera and bettery. Even with addional telemetry transmitter and OSD and Second GPS, and Lidar.
I post changes between original MP settings from APM and what is now on Pixhawk. Maybe I should change something.

Hi Michal,
Ensure your battery is good! Your voltage is variational down and up several times during your flight.
I also have a Tali and replaced the old 5200mAh battery that did not manage loads.
Regards Espen

Batteries looks good. Not sure how accurate is that voltage metering board but definitelly works. This is original battery with 10C only so up to 52A, second one has 52A and is brand new almost like stock one.
I wonder what was with transmitter RC3 (previously 1012-2012 and now I got 1108-1910). And in the middle is about 1500

I have the same instance in stabilized mode once I take quad out of loiter, poshold, or althold my quad will also skyrocket its over powered and in i guess no autopilot commanded modes actual hover throttle is needed to make them hover. Does that make sense?

I checked first log for battery and there was much more hoover in stabilize mode. And looks ok.

I wonder how it was set in APM because it works well in Stabilize and Loitier with throttle in the middle position. Now Loitier works fine (I think it’s MOT_THRT_HOVER settings) with 50% throttle but in Stabilize is really too much.

I was looking at your latest log. Seems like Altitude is a bit bumpy, so the voltage variation.

Did you perform the initial testing / setup?

Not yet. I wanted have steady hoover before I go for some autotuning. So I fly in backyard trying hoover at about 2m height or so. Last time I wanted to land and RTL from battery failsafe turns on and quad goes up to 5m, and than land. Maybe little upside down at the end but I think that was my fault with throttle in wrong position to disarm.

My tip is load some initial standard parameter, follow setup guide, motor test and calibrate etc. Then try to lift and control drone n stab-mode. Then do initial setup, then get some help to set up filters, then maybe Autotune. Ask Dave or other experienced for help here.
Regards Espen

Take @flyespen advice. You are on default parameters so really shouldn’t even be flying. The Initial Parameters Setup screen in Mission Planner will get you to a pre-1st flight condition and then you can tune from there. Auto Tune is a few steps away.

Strangely but after that Initial Parameter Setup (props, cellcount, bat volt) and saving them hexa flies on first test in stabilize, and then I checked Loitier and was ok, after landing and power off… it stop work correctly. I loose completly pitch axis. And front motors seems to work “faster” than rear and hexa flips on its back at least on 3 tryes. Roll works fine I think.
After going back to previous settings it start to fly again ok. Loitier was fine and stabilize as well, without rolling on back. I check logs later and params which could changed in flight.
But after doing initial setup, radio calibration… throttle in stabilize is still lower than 30% and in Loitier works fine around 50% (stick position).

I thinked I have problem with MOT_PWM_MIN and MAX settings. I had 1000-2000 and should be 1100-1900 so I set it to 1100-1900, but nothing changed

I checked throttle input (transmitter) in the middle (about 50%) shows 1500 in radio calibration, and when armed Pixhawk on servo outputs gives 1700 instead, I tried to recalibrate ESC’s but it didn’t change anything. So I think ESC calibration is fine.

After all I have to set MOT_THST_EXPO to -0,6 insteed 0,6 which was previously. Now I have 1500 input and output about 1500 as well… so that looks good now. In transmitter there’s “simple” set for throttle so there’s no mixing or any expotential, maybe I should change that in transmitter instead in FC?
I have Devo 10 with Deviation so it works as 12 channel transmitter. But because I use standard RX705 I can set only 8 Inputs PPM to FC and 4 addional outputs for servos or something (gimball steering and recording and landing gear which I don’t use right now at all).

I goes for few minutes test flight. I have to raise mot min throttle a little because motors doesn’t start at same time. First in stabilize mode it drifts a little to left or rear but now with 50% throttle it hoovers great. Loitier was fine also (but Pixhawk had to change Throttle Hoover to maintain stable flight I think from 0,3 to something higher - I’ll check that later but I think that will be now about 0,5 as I wanted). GPS works great in bledning mode, but doesn’t show all Sats on OSD, just primary one, maybe I can change it later.
In Loitier I also try to hit near wood fence :slight_smile: and proximity sensor and object avoidance works great, stopping and going back from obstacle. I didn’t have any problems with compass and TFmini also working toogether.

Michal, Please run the Motor Test from MP and then adjusted the MOT_SPIN parameters so all motors starts simultan when armed. Regards Espen

1 Like

I left Motor spin min at 0,03 instead 0,15 and that was this problem with wrong starting spin points for motors. I checked and they start at about 13% so now all should work fine. I’ll test tomorrow if I have good weatcher. I left Mot spin armed at 0, I just like it like that.

That is how it’s performing right now. I think I have to recalibrate accelerometer again for better start. But overall works fine. I start from stabilize, switch to AltHold and later was Loitier. I also fast check obstacle avoidance on nearby fence.
What do you think?

1 Like

I think 1 .bin flight log is worth 10 videos.

1 Like

I forgot to add it :slight_smile: sorry
I never use logs before, so If someone is familliar with it and can help to tune it or tell what is wrong which I didn’t see for now (I know I have to learn more for sure, but that take some time and hope not to many crashes). I didn’t use any filters or autotuning before, so can’t tell how it’s feel to fly some better configured hexa or quad.