Servers by jDrones

Other ground stations not working?


(brad112358) #1

The current Mission Planner version on Windows works and I can upload and download waypoints, but I can’t seem to get any non-windows ground stations to work.

Tower and Tower Beta on Android doesn’t connect. I have selected UDP and the port is set to 14550. Is there something else I need to do?

qgroundcontrol version 3.2.4 on Android and Linux both connect just fine and I can download waypoints I uploaded via Mission Planner, but attempting to upload waypoints results in an error message:
"Error durring Missin communication with Vehicle: Vehicle returned error “Received mission item out of sequence (MAV_MISSION_INVALID_Sequence). Sequence 1.”

Apm Planner 2 version 2.0.25 on Linux won’t connect. Again, I have added a UDP connectin at port 14550. I see the broadcast packets on this port from 192.168.99.1 via wireshark, but Apm Planner 2 does not see the connection.

I expected all of this to just work. Have there been recent changes in the ardupilot code which cause incompatibilities?


Qground Control Sequence Error
(Dave) #2

I had trouble getting Tower to connect initially also but it’s now working. I’m not sure if it was due to the last firmware update or not. I do find QGroundControl on Windows to be problematic also in this regard. APM Planner 2 on Windows seems to work OK.


(Chris Olson) #3

That will happen with QGroundControl due to the Home waypoint setting. Just leave it at default and Home will be set at vehicle arming. You can drag the Home waypoint on your screen to where you want it, but don’t set an altitude for it or anything (tested on Android).


Qground Control Sequence Error
(Olivier Brousse) #4

I’ve seen similar issue as yours with mavproxy and qgroundcontrol on Linux, but haven’t checked yet whether it was due to home point issue as Chris mentions. It’s been all good on windows mission planner and qgc.

Btw Mavproxy on windows also works well for monitoring but there’s a known outstanding issue with editing missions independent of this, due to Windows own way of implementing multithreading.

http://ardupilot.github.io/MAVProxy/html/getting_started/download_and_installation.html
https://github.com/ArduPilot/MAVProxy/issues/129


(alandal) #5

Hi dkemxr, so combination of IP of 192.168.99.1 and port of 14550 worked with Tower for you? well both Tower and Beta are not working with latest firmware on 2450GPS. Thanks.


(Dave) #6

The IP is how to browse to the Web Server. To use Tower 1st you have to connect to the SkyViper via Wifi on your device (default SSID, SKYVIPERGPS_230F30 )then Connect to the SkyViper via UDP on port 14550.


(alandal) #7

Thanks. That’s what I did, but there’s nothing happening after pressing “connect” .


(Dave) #8

Not sure what to suggest. I find that Tower works on Android, QGC works on Windows and IOS and Mission Planner and APM Planner 2 works on Windows.


(alandal) #9

found this page :http://ardupilot.org/copter/docs/skyrocket.html#using-other-gcs-software. Towards the page end, it has the following:

The SkyViper uses MAVLink2 by default, which doesn’t work with some older GCS software (such as Tower). To use those GCS versions you need to change the parameter SERIAL1_PROTOCOL to 1 from the default of 2. That will allow MAVLink1 GCS implementations to connect. As the SkyViper uses UDP broadcasts you can connect from multiple devices at once.”


(Dave) #10

Ah right, sorry about that. I changed that some time ago and forgot I did it…


(brad112358) #11

Missing this step was my problem with tower as well.
Tower development seems to have stalled which is sad because it still seems to be the best GCS for android. I don’t think we are missing much without MavLink version 2, but it would be nice to add RTP to allow viewing the video stream from tower. Has anyone gotten video to work with QGC?

I’m still having trouble setting waypoints from QGC.


(Dean) #12

I have successfully made and flew 15 missions at -12 using QGC beta. I am still learning and testing features and general parameters in QGC. I would like to know how to automatically turn on video. camera and rotate SV. in flight path.At this point when I send it on a mission I use the controller to start record.Also I could never get the mission to load unless I first turned off the transmiter then uploaded to SV. I am getting about 5 min flight time and a distance of 2100ft at 10mph. Its pretty sweet!!


(Dean) #13

After many missions I can no longer load missions in the skyviper. I get the following message

Any help would be great, thanks


(peterbarker) #14

After many missions I can no longer load missions in the skyviper. I get the following message

[f062b1fa8589eabe99eb95ab4de77b5c481b66e5_1_689x192.jpg]

Any help would be great, thanks

Please provide a telemetry log (from your GCS).

Yours,


(Dean) #15

peterbarker http://discuss.ardupilot.org/u/peterbarker
December 7

After many missions I can no longer load missions in the skyviper. I get
the following message

[f062b1fa8589eabe99eb95ab4de77b5c481b66e5_1_689x192.jpg]

Any help would be great, thanks

Please provide a telemetry log (from your GCS).

Yours,

Visit Topic
http://discuss.ardupilot.org/t/other-ground-stations-not-working/22560/14
or reply to this email to respond.

In Reply To
InMotion http://discuss.ardupilot.org/u/inmotion Dean
http://discuss.ardupilot.org/u/inmotion
December 7
After many missions I can no longer load missions in the skyviper. I get
the following message [image]
http://discuss.ardupilot.org/uploads/default/original/2X/f/f062b1fa8589eabe99eb95ab4de77b5c481b66e5.jpg
Any help would be great, thanks

Visit Topic
http://discuss.ardupilot.org/t/other-ground-stations-not-working/22560/14
or reply to this email to respond.

To unsubscribe from these emails, click here
http://discuss.ardupilot.org/email/unsubscribe/4ad5ccfa3d40169d88b0e6b56ef2fc0b9776bd9b18a81c979f319e059d08a1c2
.

2017-12-05 17-50-09.tlog (1.37 MB)


(peterbarker) #16

2017-12-05 17-50-09.tlog (1.37 MB)

Well, that log definitely seems to cover the problem you mentioned.

This could be explained by having multiple GCS on the same network
segment. e.g. both Tower and QGC running at the same time. Are you doing
that?

It could also be explained by some parameter changes - have you modified
many parameters from stock?


(Dean) #17

No, I run only one ground station,Qgroundcontrol. But I have it installed
on my android tablet as well as my phone.I have run skyviper app and
Qgroundcontrol at the same time.
As for parameters changed, radio signal strength. From 5 to 8 and mode
button changes for drift and circle functions.


(Kevin) #18

I have tried changing the Serial1 Protocol to 1 but still have the same issue, anyone else?


(Albert) #19

Greetings!
I am wondering if you have been able to get the onboard camera to display in the Tower app, and if so, how you made this happen.
Thank you.


(Dave) #20

No. Closest to that was displaying it in a Windows Laptop using VLC. It works but it’s laggy.