Oneshot125/42 blhelis

I wanted to ask when the oneshot 125 will be repaired because it hasn’t been working in the arducopter for some time. I understand that blheli32 offers 48khz engine timing which leads to increased performance, and blhelis are impossible with dshot on the arducopter … But now many blhelis controllers have the ability to upload firmware e.g. through the JESC configurator which also offer firmware with 48khz timing for blhelis and old controllers can be used with oneshot 125 or 42, oneshot 125/42 will certainly be faster and will not filter with signal delay, and 48khz timing will give less power consumption.

1 Like

BLheli 32 and Dshot up to 1200 is supported on arducopter, but not on all flight controllers.

I’m using Oneshot125 without issue

Do you have 32 or blhelis regulators? In one of the hexa models I have HGLRC 30A600 controllers / supporting min. DSHOT 600 / oneshot / pwm. In version 3.6.6 I used them as oneshot125 and acted as oneshot 125. In copter version 4.0 the same regulators despite the oneshot 125 setting are controlled in the program as pwm (1000-2000us). In the motor test (when I have set as oneshot 125 turns the engines but the controller error shows regardless of which one I control 6. Problems with oneshot 125 have been reported in the internet for a long time and still there is a problem. I don’t know if there is a problem with blhelis 32 because in this only model on the arducopter I found .
Post here:

Yes, I understand that I have a blheli32 on a quad and dshot works on an arducopter. The problem concerned the operation of oneshot 125 on the blheliS terminal which in the older version of the copter worked correctly as a oneshot

Having the blhelis regulators up to a point I thought that oneshot 125 was working for me, but as I checked the logs, I had Motor out (1300-1800us) or pwm and in the motor test in the latest mision planner I have a message about no communication / after switching to PWM everything is ok. I think many people think that when they turned on oneshot 125 and the drone for years it uses oneshot 125, while for me the driver without signaling uses pwm despite setting oneshot 125.

Hi .
The oneshot 125 protocol is analog. It is a PWM with a max pulse length of 125us. There are no control signals because it is not like a dshot digital system. Besides, my HGLRC30A 3-5C blhelis regulators worked well in oneshot 125 in the older arducopter version. Now they don’t work and the Pixhawk 2.4.8 driver controls them as PWM without my knowledge .

Poza tym czy pisałem ,że problem dotyczy dshot 1200?

The post refers to RaspberryPi based boards - I have only ever used with STM32 boards and they seem to work fine. I am using LittleBee ESC’s - regular BLHeli (silabs chips).

Oneshot125 works fine on my Pixhawk 2.4.8 with Copter 4.0.0. Main output min and max throttle.

1 Like

For me, there is no doubt that the oneshot 125 on my pixhawk 2.4.8 with software fmuv3 copter 4 on the hexa frame does not work. It works correctly as PWM without giving any signals that the controller is not in oneshot mode. Of course, the log shows Motor out at the pwm level (1000-2000us). Only an attempt to test the engines in the latest beta version of MP makes the tested engine spin, but in a moment I have a communication error message. My error would be possible if the software copter 4.0 in motor out shows not the control signal up to 125us for oneshot 125 but the signal level of the regulator (but it would not be from 1000 to 2000 only from 0 to xxxx). So I will check how I get home with the oscilloscope the control signal of the regulator when set in copter 4.0 to oneshot125 and there will be no doubt.

Yes, I see that the signal you have 125-250us, which is typical for oneshot 125. Do you have regulators blheli32 or blhelis or some other?

Please see in the log if you have motor out values in the range 125-250 or also 1000-2000. In the second case, it would appear that the log motor out always shows the value in the range 1000-2000 despite the signal e.g. oneshot 125 from the range 125-250.

It does that in the log for Dshot. You can see this on the status screen in Mission Planner on the bench. For that matter you can see Oneshot125 also.

The logs show the same as what’s shown on the O-scope output.

Here it the same setup configured for Dshot150

Oops. I was looking at the Main output with Dshot which is invalid. Have to switch to aux outs for this graph to be valid.

OK, here we go.

Thank you very much for the information. When I come back from the delegation I will check with an oscilloscope what is sent to me in the controllers ESc. In the old version ac motor out for oneshot125 was from zakesy 125-250. I know it for sure because I watched in ac4 as you write motor out is from range 1000-2000. The param file I have continued from older versions. I used to think that blhelis works on the arducopter in dshot and remapped the engines to ports that support dshot. I am curious if I am wrong, but two days ago in the latest version of MP beta when testing the engines every time I received a warning from MP, and after switching to PWM (0) not anymore. It would be great if my fears were unfounded. Many thanks once again.

I am using Oneshot 125 on my Octo with Holybro Tekko32 Blheli_32 ESCs without any issues. I am on AC 4.0.1-dev

Oneshot 125 is coming from the main PWM outputs of my flight controller

Here is a sample plot from when I went flying today

The case where you have no choice right? Not enough Dshot outputs :disappointed:

Yes :disappointed_relieved: I wish I could get 8 dshot outputs from the Main outs of my Cube. Since I can’t I am limited to Oneshot 125

Thanks for the info. I’m just surprised why you didn’t switch to dshot to use rpm with BLheli32. Please answer, because I had to order these regulators in a few days because of telemetry. Your RCout chart shows the range 125-250, which is how I thought for oneshot. For me, it is rc OUT JEST1200-1700, which is how PWM is, despite the esc setting on oneshot 125. I have to solve this problem … it seems that in betaflight (I have 2 models) everything is easy and hassle-free …

Wait a minute guys. Something was ringing a bell with this issue. I have a PixRacer on Copter4.0.0 (well 4.0.1-rc3) and it’s set for Oneshot125. So I dusted it off (cold and snowy here) but on the Status Screen in Mission Planner it’s showing 982-1920. I guess I’ll scope the output to confirm but now I don’t know what gives here. Clearly the Pixhawk 2.4.8 was in the Oneshot125 range but why not with PixRacer. No IOMCU but so what!