Servers by jDrones

One motor stuttering

(Sachin) #1

Hej,
A newbie building the first heavy drone here and one motor keep stuttering from time to time. I changed the ESCs among motors, but only one motor has the problem. I checked the resistance for soldering and did the ESC calibrations in mission planner but still has the problem. Can someone help me to solve this?

Copter setup:
Cube black on quad X
Sunnysky’s EOLO ESC 50A
Sunnysky v4008-17 KV380
6s Lipo

Here is a video of the case:
https://vimeo.com/342257880

Also does anyone know what firmware is used in EOLO and a suitable protocol?

Thanks!

(Dave) #2

The specs on those ESC’s only mention Oneshot and Oneshot125 timing so I would use either standard PWM or one of those protocols…

1 Like
(Sachin) #3

Thanks dave that is a useful info. I tried changing protocols but problem remains in one motor.

(Mike Boland) #4

Which motor is it?
I have just had this happen on a PixFalcon. Motor 1.
If I move the connection to another motor the problem moves, so its something out of that port.
I was getting ready to change motors and ESC’s.
Standard PWM ESC’s.
Your video was a bit quick, did the motor spin at all?
At what throttle setting did it strat to do this?
We have also had issues with Shot being used on standard PWM where we had to change out the Shot ESC’s.

1 Like
(Shawn) #5

Try to rule mechanical issues first, screws too long touching the wrong part of the motor, something like that.
Then swap outputs at the pixhawk to see if the problem stays with the motor/ESC or moves to another motor.
Then probably change out the motor and then the ESC

1 Like
(Rickjames) #6

Check your solder job on the 3 wires from motor to ESC of the trouble motor.
Had this issue before and any one of the 3 lose will cause your system

1 Like
(Sachin) #7

For me it’s motor 4. And the problem stays with the motor when change ESC. Sorry about the video quality, the motor stutters only from time to time in throttles below 10% mainly, like in the beginning of the video. I am using standard PWM, tried changing to other protocols , no difference.

(Sachin) #8

After considering all your suggestions, I re solder motor connections to ESC. And checked with a servo tester, it works fine. Re did the motor mounts with extra spacers , so the screws aren’t touching the bottom of the motor and test again, works normal.

Then, mount it on the quad and throttled it slowly, 50% of the time it stutters at lower throttles. changed ESC connections, problem stays with the motor. Even changed the pin-outs from cube, same result.

Observation: motor 4, the faulty one slightly heated up than others.

What am I missing here? I will look again for mechanical mishaps, but do you have any solutions for this?
Thanks.

(Mike Boland) #9

If you have moved everything around, changed ESCc’s and it is still motor 4 then it looks like a winding short on motor 4.
New motor required.

1 Like