Servers by jDrones

Omnibus nano v6 - > no gps?

I’m entering into Plane with a zohd orbit wing, with a Omnibus nano v6 inside. I ultimately configured everything (servos, receiver…) but i cannot get gps antenna m8p to work. I wired it to uart6 as docs says. Serial port on protocol 5, tried gps type on 1 (auto) and 2 (ubx), none works. Before that, same FC was flashed with inav and gps was working ok. What’s am i missing?

Which serial port did you configure for GPS in firmware? Should be 3.

Correct, it’s serial3.

S

after an year, i reopened my little unfinished fpv wing with the omnibus nano, flashed latest 4.1 master, and still same problem. I could make other devices work (compass, telemetry, etc) but the GPS, i tried everything i could… any ideas?

please upload a param dump

new_1.param (18.7 KB)

here you are

those params look ok. what exact message do you get in MP, is it „no fix“ or „no gps“?

maybe post some meaningful images of how you have it connected.

i simply get “no gps”…

i think we‘ll have to look at the hardware now…

as you can see in the second picture, yellow and white cables from GPS unit are connected to TX6/RX6.
The other cable from GPS are compass, connected to RX3/TX3 and an external compass is appearing in MP correctly. Thus “NO GPS”.
There’ also yellow/black couple wires to RX1/TX1 for telemtetry, also working ok

hard to tell without knowing the GPS connector’s actual pinout, could you post that too?
how do you power the 5V rail?

5v is from the omnibus board

ok, i‘m running out of ideas. one thing i had fail on me quite a few times are those micro-connectors. plug them in and out a couple of times and the wires tend to break at the crimp-joint most of the times. might be worth checking the gps cable thoroughly.

thanks for spending time on this… i’m also out of ideas. will try to change connectors…at least i will try another gps unit, however my suspect is something wrong on the board (i mean… config, sw or whatever).

A good opportunity to replace it with a Matek H743-Mini :slight_smile:

Although, I do still have a Omni F4 Nano flying in a Plane.

dave, do your ombibus works with gps? can you share some info about it? params, fw…

Hi Steve,
Sure, parameter file attached. This is an Omni F4 nano V6 (point nothing) version on 4.1.0-dev but the serial port assignement will be the same if you are running Stable.

I should add that I asked Basti @vierfuffzig for his parameters file when I 1st put this FC in the Drift plus the fact he ported Ardupilot to this FC so you are talking to the right guy :grinning:
Drift Omni Nano V6 V4.1.0-dev.param (15.9 KB)

thanks dave, i did a couple of commits on the nanov6, but actually it was henry who did the initial port;)

Servers by jDrones