Omnibus F4Pro cannot be flashed with newest firmware

Trying to flash my newly received Omnibus F4 Pro (purchased directly from Airbot) fails. I can flash the newest ombibusF4SD firmware in Betaflight (meaning hardware probably is OK), but using dfu-utils I consistenly get the following output and error:

sudo dfu-util -d 0483:df11 -c 1 -i 0 -a 0 -D arducopter_with_bl.hex -s 0x08000000
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util / Tickets

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device…
ID 0483:df11
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 2048
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08000000, size = 2760652
dfu-util: Last page at 0x082a1fcb is not writeable

The firmware (arducopter_with_bl.hex) file is the latest from the repository.
I’ve tried various options, also updating with Mission Planner under Windows and with Qgroundcontrol in linux, but all fails. I’d be greatful if someone could push me in the right direction.

Loading a bootloader with DFU — Dev documentation too many options

1 Like

Tried both the examples inthe Dev documentation, but unfortunately this gives the same error with the arducopter_with_bl.hex file. I could load the bootloader (omnibusf4_bl.hex) but not arducopter_with_bl.hex.
Any other options?

If you’ve got the bootloader on then Missionplanner should be able to flash the firmware

No real luck so far. The files arducopter.hex and arducopter_with_bl give the error, omnibusf4pro_bl.hex does upload but when trying to open in MP the device does not seems to be connected to a com-port. MP is the latest version, as are the hex files.

I’ve tried it with 2 omnibus f4 pro boards and one omnibus F4. Same result for all boards

If you are using df-util upload the bin file. ardupilot/omnibusf4pro_bl.bin at master · ArduPilot/ardupilot · GitHub

I use Betaflight configurator in DFU mode and flash arducopter_with_bl.hex

@andop1per: dfu_util does upload the bootloader but still no way to install any firmware files afterwards
@LennyB01: Using Betaflight Configurator in DFU mode, I can install the regular betaflight firmware (goes through the entire erase/flash/verify cycle) but trying to install the arducopter_with_bl.hex does the erase but hangs in the flashing phase (immediately shows full orange progress bar) does not end.

The steps I’ve tried so far are:

  1. Boot OmnibusF4pro in DFU
  2. In Betaflight Installed newest OmnibusF4SD firmware
  3. Reboot in default mode, checked if the board works in Betaflight (which it does)
  4. Reboot in DFU mode in Betaflight
  5. Install omnibusf4pro_bl.bin [and in different series where starting from scratch tried to install arducopter.hex and arducopter_with_bl.hex]
  6. Try to open the board in Mission Planner: no COM-ports are available

The procedures described here have worked for me across many boards but some have used this tool when stuck.

1 Like

@dkemxr: I’ve run the ImpulseRC driver fixer but unfortunately it did not change anything. After installiing the ardupilot bootloader the board was not recognised. In zadig it did not show any USB device and in Mission Planner it did not fire up a COM port
@andyp1per: thanks for pointing to your helpful youtube instruction video, I get stuck after about minut 2.55. There the dfu-util had flashed the bootloader. I get that far, but after rebooting in normal mode (not DFU), the board does not trigger a COM port and is not detected by Mission Planner

There were some memory/compilers issues with the newer bootloaders, it would be worth trying with one from (say) a year ago

Bingo! Thanks for the suggestion @andyp1per. I downloaded the bin file of 2019 which, after upload with dfu-util could boot the board. I had to upload the ardupilot firmware on my windows 10 setup, after which I could continue the configuration in Mission Planner under linux (debian/wine). Great help!

@tridge it seems the bootloaders are still broken.

I don’t think the bootloader is the issue.
I just loaded Tools/bootloaders/omnibusf4pro_bl.bin on a MatekF405-STD (I don’t have an omnibusf4pro) and loaded the omnibusf4pro latest copter firmware. Both loaded fine. It then fails to find the barometer (as expected, as omnibusf4pro baro is different from MatekF405-STD), but the fact it got as far as trying to find the baro means the bootloader is fine.

@hwurzburg do you have an omnibusf4pro you can test? I suspect it is fine, but it would be good to check.
maybe newer ones have a different set of sensors?

I have one I can try

1 Like

I tried both the omnibus F4 Pro, the omnibus F4 and the MatekF405. I can confirm that on my hardware the latest bootloaders can be uploaded with dfu-util, but then both boards do not boot. When I use the older bootloader, both boards do boot and can be configured with Mission Planner (both on a Windows PC and on Windows on VirtualBox).

@tridge yep…just loaded master arducopter_with_ bl.hex on an omnibusF4Pro using the wiki’s recommended STM32Cube programmer in DFu mode…no problem, connects fine to MP

1 Like

I uploaded latest bootloader from master and Copter-4.1 - both worked fine. Have you tried re-installing the driver package that comes with mission planner?