Omnibus F4Pro cannot be flashed with newest firmware

I reverted back my OmnibusF4pro to Betaflight. Tried to upload arducopter_with_bl.hex (newest) with dfu-util. This gave the same error as reported before. Uploaded the most recent omnibusF4pro_bl.bin, which upload was completed but at reboot the board did not show up as USB device/COM. After upload of the 2019 version of omnibusF4pro_bl.bin and reboot, the board shows up in the USB-devices list and shows as COM device in Mission Planner. I have the latest (Aug 2021) version of Mission Planner installed with all drivers and no erros.
For me the bottom line is that, at least for my hardware/OS/software environment the current versions of the firmware are not functional whereas the older version are.

my best guess as to what is happening is you’ve ended up with multiple drivers installed for the same USB vendor/device ID in windows.
MissionPlanner has a button on the control-F menu to fix this, called “driver clean”. After pressing that and waiting a few minutes then install the drivers MSI package from here:
then reboot. That should cleanup the driver conflict. Please do let us know how it goes

@tridge: have reverted back to betaflight OMNIBUSF4SD, cleaned the Mission Planner drivers and reinstalled them, uploaded the latest omnibusF4pro_bl.bin, but still when I plugin the board in the USB port it is not recognised by windos as USB device (also not in linux). When again, with the same procedure installed the 2019 version of omnibusF4pro_bl.bin it is recognised, I can install MP firmware and configure the board.
For me this is solved. Again for me the problem is solved and I hope that, if other run into the same problem are helped with the solution of using an older version of the BIN file