Omnibus F4 V6 Flight Controller

Anyone tried or at least knows if this is supported with the chibios firmware. Ive tried a V2 and got to the point of everything working execpt for the SBUS in, as it does not have the subs/ppm solder tab on the board.

I was about to buy the V6 version, but wasnt too sure if its going to work.

Cheers steve…

Hi, 5.1 seems ok, if you do not need too much UARTs, look there

1 Like

Hi Steve,
I have just got this board to trial it. I have yet to Flash ardupilot though. It should work just fine however, you will not have access to all 5 uarts at the moment. I am looking to build a ‘new board’ for the v6 so that we can access all 5 uarts.

I will let you know how I get on.


1 Like

I have just flashed my V6 board with copter3.6-dev and it works for board type ‘omnibusf4pro’. As I thought you won’t currently get all 5 UARTs though.
I am working to resolve this. Matt

1 Like

Is this the same as the mini v6 board? I was thinking about fixing the hwdef for that board, so we can use esc telemetry.

1 Like

Do you mean the v6 nano board? I haven’t come across a mini version of the board.

1 Like

Sorry, you’re correct. Nano.

1 Like

To be honest, I am not absolutely sure of all of the differences between the nano and the ‘regular’. I know that the regular has 6 pwm vs the 4 on the nano. I know that the regular has 5 UARTs and I think that the nano only has 3 UARTs (not 100% on this though). So they will need to be set as two separate hwdef.dat files. If you do fix the telemetry on the nano would you be able to explain to me what you did so that I could add the ESC functionality for the regular board as well please? Thanks, Matt

1 Like

Nano v6 has 5 UARTs as well.
But the existing hwdef only uses 3 of them.
The hwdef also has various analog inputs listed, that don’t actually exist on the nano v6 board.
SO, needs some work. But should be relatively simple. The manual lists all the pin assignments. I think I just need to add the line specifying uart4, and then add uart 4 to the order of uarts line…


Supposedly the Nano V6 has 5 UARTS also. I have one flashed to the “Latest” 3.7-dev firmware specifically for this board but haven’t connected anything yet, waiting for other parts.

1 Like

Thanks for working on this board and the replies. I think ill go for the full size V6 and give it a go at somepoint.

Cheers steve…

1 Like

My nano v6 finally arrived, a month after ordering it…
I haven’t done much with it yet, but was doing some prep work last night.
I learned that in betaflight, it shares the same target as the full size v6. All the pin assignments appear to be the same.
I spent a while looking at the pin assignments and timers, etc, and think uart4 (esc telemetry) should be able to work. But I’m not a programmer, and would imagine the person who made the existing hwdef for it has a reason for not enabling it.
I’m going to try it though… I’m slowing working on setting up my development environment. Matt, if you’re already set up for compiling arducopter, the changes I have in mind are very simple. add one line, “PA1 UART4 RX UART4 NODMA” and add “UART4” to the end of the order of uarts line.

Ok got the F4 V6 on the bench, there is some paper work that came with mine from Unmanned Tech.
It says on paper work Uart 1 is SBUS, but couldnt get the receiver to work with that, changed to Uart 6 and bingo worked fine.

Now flashed with Omnibus F4 Pro with todays date, 29/08/18 , loaded fine.
But still no SBUS connection, no receiver inputs so cant calibate. Also getting weird problem with EKF Vertical position goes red and sky high, no idea on that.
Will have a look again see if theres anything i can do, but at the moment no luck (

Try flashing the v6 nano board to it, and connect things to the ports as they are on the nano page.
Receiver input is actually on the LED output pin!

The paper that came w/ them doesn’t matter… The ports are different for Arducopter (for some reason… I haven’t figured out why we can’t just make them work like they do in betaflight)

Cheers that seems to have sorted out at least one problem, now have SBUS working thanks alot. Now to solder the gps/mag and see if that helps with this EKF error ---- onwards to more soldering :slight_smile:

EKF was down to accel’s needing to be calibrated. Now stuck at the compass calibration routine which i’m not the only one with this problem. Damn so close )

1 Like

OK, finally got my compass sort of working. MY tx-rx cabling was the wrong way round, doh!

Went to calibrate compass, and managed to get to 99% and it go stuck, so i just clicked accept.
It didnt go too well, EKF compass variance constantly so i decided to try and use my compass settings from another pixhawk.

Typed them in and it seemed to be spot on, but now i have problems with as soon as i move the drone the EKF variance thing flashes red and get error compass variance on mission planner screen, but it does follow which was is north etc. Weird!

Hi did you had some success with this board? I’m just looking for a small FC with telemetry working. Was also looking at the F4 Corner Nano, but not sure it’s supported yet. It runs target betaflight OMNIBUSF4SD as I know.

I got the board working w/ mavlink telemetry. But, ESC telemetry is not working. I haven’t tried modifying the hwdef yet. (I’m not set up for development… Gotta load ubuntu and set everything up, etc. I haven’t had time to try yet.)
My details are in the “MicroArduCopter, 3” props, Omnibus Nano, Success" thread.

I have the board up and running fine, but i was looking for more than 4 pwm outputs and as i am using the nano version it only supports 4, really could do with 2 more.
Apart from that, it works great )