Omnibus F4 V5 & V6 Setup - Application Race Quad

RC input is to the LED pin on this board running Arducopter.

Edit: Sorry, that’s for the Nano V6.


I should have answered before but in the meantime I was on holidays and away from this build.
I was trying to do the on-board calibation since the “Live Calibration” didn’t seem to be available in the new version of Mission Planner but after all there’s a way to still calibrate the the compass using Live Calibration, which is holding CRTL key while clicking on the “Compass Calibration” in the Mandatory Hardware. This will actually display once again the Live Validation which allowed me to calibrate, “successfully” the compass.

I did contact Matek and they told me:

“It is neither FC nor compass module issue.
Try “live calibration””

So… I did and it worked…

Hi @IAMMATT, Has this happened in the meantime? :slight_smile:

@IAMMATT with the omnibus f4 v6 aio should I be using the labeled pads on the board to set it up? I have been trying to figure out what port on the v6 board I should be using for sbus.

Honestly, I don’t know. I don’t have a nano v6.

Looking at the hwdef.dat file here, I can see that there are comments that rcin can be on the led strip and sbus can be on uart 6. Have you tried the labeled sbus pins first? If you have and that didn’t work, try the led and/or uart 6 pins.

its not a nano. its the omnibusf4v6 and looking at the hwdef it appears to be on the led. i’ll double check it before I pull this board out.

You must solder to the LED pin. Specific board details, as of current version, can be found here:

1 Like

Still concerning the OMNIBUS F4 Nano V6, After playing around with the 3D printer a little bit to get a few parts for the camera gimbal and legs for the quad, I decided to go and install the newest version of arducopter firmware ( 3.6.11) in the OMNIBUS F4 NANO V6.

Now… I’m not sure anymore if it ever worked… but I’m having some trouble getting the Battery monitor to work. As soon as I try to activate it I get “This feature is not enabled in your firmware”.
So… that’s definitely not a good sign. Have you ever got this kind of error? What I found in on the net is that most of the times people with similar problems just end up trying different firmwares and sometimes it works and nobody knows why.

Any ideas?

Voltage sense works on my F4 nano V6 with 3.6.11.

So… I guess I’m doing something wrong then. So, you don’t get “This feature is not enabled in your firmware” I assume.

After all it was given to BATT_VOLT_PIN which was set to -1… :frowning:
Sorry for wasting your time!

I accidentally upgraded to 4.0, but now my Beitian BN-880 is in Bad signal health. Maybe version 4 does not support omnibus V4? Or do I have to change some parameters?

That’s odd as there has been a fix in for this:

I would recommend posting about it here as this is where you are most likely to get help with this:

To answer your question it should work and you shouldn’t need to do anything with parameters as there are param conversion functions that handle this automatically when you upgrade from older to newer code versions. So long as you don’t use the ‘load params’ button in mission planner after flashing the new firmware.

ok, I also posted where you indicated me. Maybe the problem is that I was coming from the old dev version from September 18… ArduCopter V3.7-dev.

after letting the drone outside for around 20 minutes I had a 3D fix. I think it’s related to Beitian BN-880. Never had this problem before. Do you know if last position is stored in GPS or and also in ArduPilot config? Could it be the small button battery on GPS?

Being honest, I don’t know alot about gps protocols. I do know that they have what’s called a ‘hot start’ where by they have already been on very recently and it takes less time for them to confirm satalite signals if they have recently been using them. If they have not been used recently then this is refered to as a ‘cold start’. They will take longer to get a good fix. I believe this is handled by the gps unit it’s self though and requires no interaction from ArduPilot.

I have the same gps unit as you and have had to wait on the order of 20 minutes to get a good fix (hdop < 1) if I am in a built up area and on a cold start. In a wide open field and depending on weather etc, that time comes down to more like 5 mins.

As far as I know ArduPilot doesn’t do anything like injecting the last known home position into the gps. I don’t see that this would be a useful feature or good idea (but I don’t know I’m just speculating).

Perhaps, the reason that you are seeing the issue now is because of the fix that went into 4.0. In other words, the version you were flying previously wasn’t correctly determining the health of the gps so it created a false sense of everything working correctly before but in fact the behaviour you see now is the correct one. Again, I am just speculating.

1 Like

Hi Matt,

I’m new to drones/Ardupilot and consider to buy this Eachine Tyro129 DIY kit. It seemingly has this Eachine GPS F4 flight controller. May I ask you a few questions?

  1. Is this FC the same as Omnibus F4 which you managed to fly with Ardupilot? (My aim is to use Ardupilot on my drone…)
  2. Can you guess which version this FC is by looking on its picture? V5? V6?..
  3. It has GPS in its name… however does it indeed has GPS built-in? Or do I need to buy it separately?
  4. For now I don’t want to buy a transmitter/receiver/goggles but rather use QGroundControl to (a) control the drone and (b) to get video stream from it. My laptop has WiFi and Bluetooth Low Energy. Can I use any/both of them to connect laptop and the drone? Or do I have to purchase some additional hardware for this?

Thank you!

Hi Sim_Tov,

To answer you questions:

  1. No it is not the same as an Omnibus F4.
  2. No
  3. That FC doesn’t have GPS built in you would need to buy a GPS.
  4. I suggest that you buy a transmitter and receiver as you will really struggle to setup a drone without one. You need to be able to fly it in the most basic modes first to enable you to tune it. Some will say that you can fly it via a joystick connected through mission planner but I really don’t recommend this if this is your first drone as just adds more complexity and flying in this way is a lot harder/impossible if the drone is badly tuned. With regard to WiFi, you will need a WiFi telemetry module to be able to connect to the drone via WiFi.

I suggest you go through the wiki on setting up your first drone and follow the instructions to make a simple quadcopter using the recommended/supported hardware:

Thank you!

  1. How different is it from Omnibus F4?
  2. Is it a clone of Omnibus f$?
  3. What are the chances to get this thing flying with ardupilot (your estimation)?
  4. Have you heard of somebody who managed it?

Thanks a lot for all your advises!

I realize this might not be the right forum for this but there doesn’t seem to be a forum for ArduRover on Omnibus F4 v6. Please direct me to a more appropriate forum if you know of any.

Anyways, I have ArduRover 4.0 on the Omnibus F4 v6 board and everything seems to be working as expected (SBUS, SmartPort telemetry, GPS and compass) but for some reason I can not power both the board and separate ESC from the same battery. I can power the board just fine without the ESC but as soon as the ESC is also connected to battery power, the board shuts down. If I plug the ESC in first and then the battery, the board does not power up at all. If I start all over without the ESC the board powers up again. It makes no difference whether the ESC 5V and signal wire is connected to the PWM/servo pins or not. I have tried with several different ESC:s that I know are working fine.

I have received some help from Lee at Painless360 and he can see nothing apparently wrong with the wiring. Perhaps I have a faulty board…?

I would like to know if anyone has managed to power a separate ESC on this board or are experiencing the same problems that I have?