Omnibus F4 V3S flashing problems

Lately I’ve acquired Omnibus F4 V3S flight controller (it’s AIO V3 basicly, with filter graph) and it’s running Betaflight OmnibusF4SD v4.2.2 by default. I’ve tried to flash Arduplane firmware omnibusf4 v4.0.5 and it seems to work just after the flashing procedure, but when I reconnect it, FC is not recognized by Windows (10). Flashed version was that without bootloader, the one with it didn’t work - it got stuck after the ‘erase’ part and never finished - in betaflight progress bar was showed as full (after the erasal) and ‘erasing’ switched do ‘flashing’ and stayed that way (stuck).
In case when I flash bootloader target first, and then firmware without bl, it flashes “successfully”, but there is a difference in blue LED signal -> instead of blinking rythmically (normal-normal-normal-normal), it blinks like this: normal - fast - normal - fast. I cannot find anything about blue LED blinking meaning in net :confused: . And after reconnecting, like I said, it’s not recognized - only green LED is lighting stable.
Please help, I’ve tried flashing multiple times in multiple ways, with different versions of firmware - with bl, without, omnibusf4, omnibusf4.

I fried the board, so problem solved, kinda

Are you sure you fried that board? Could you tell me how you did it? I am having fashing problems as well with the dreaded solid green light. Before I spend another 5 hours messing with this thing I’d like to make sure it’s still alive.