Omnibus F4 V3 loss of control and crash

I have a terrible problem with my Omnibus F4 V3 running Arducopter.
Please see the Video:

Whenever I arm the copter, it flys for a few seconds. Then it starts going absolutley crazy. It spins up the motors even when I move the throttle down to 0%. It does not seem to go to failsafe since then it should turn off the motors. I am a beginner with all the arducopter stuff (normally I fly raceflight, betaflight). So I am a terrible noob at Arducopter. However I followed the setup in the wiki as good as I could. Also the issue is reproduceable. It crashed my big and expensive 17 inch hexacopter. I then took the FC and put it into my 5" racequad to see if I can reproduce it- and yes I can. It happens all the time. All help is highly appreciated…00000009.BIN (264.3 KB)

Does it happen in stabilize mode? Is your barometer covered in foam?

It did happen once I think. But not 100% sure. I was switching back and forth a few times. The barometer was not covered in foam.

I’m not great at log analysis, so maybe someone else can give more specific advice…
But usually when this happens it’s related to either the barometer not being shielded from air, so the air from the props goes over it and changes the pressure it’s reading, so the altitude is wrong.
Or vibrations can cause this… Your vibrations get bad, but the beginning of the flight is OK. So I’m going to assume the vibrations get bad after the issue presents and the motors increase their output… but i’m not sure. You cannot hard mount the flight controller w/ arducopter. You’ve got to use anti-vibration mounts. Either rubber grommets or rubber standoff’s, or double sided tape foam or gell products made for vibration damping. And you’ve got to have balanced props. Arducopter is not nearly as forgiving about vibrations as betaflight.

Stabilize doesn’t use the barometer or try to automatically maintain altitude in any way… So you should first double check and do a flight in only stabilize to see if the issue is there. Beginners usually have a lot of trouble keeping the altitude steady in stab because it takes some serious thumb control, but try it… you’ll at least be able to tell if it’s following your thumb movements, even if it is going up and down more than you’d expect.

Thanks for your input. I do not think vibrations are the issue here. on my big hexacopter there are very little vibrations and the copter did go crazy too. the FC was hardmounted in both copters. kind of a bummer, that arducopter is THAT incapable of dealing with vibrations. The props are also not the issue here I think. The copter was flying perfectly with raceflight and betaflight…
My nooby opinion on the crashes is that it is the firmware’s fault. I have flown many copters even with the most crappy FC’s (kk board for exaple). and for me if I look at the video I tend to think it is a firmware error as the movements are SO uncontrolled and weird. But still any input is highly appreciated. I really want to solve this problem!!

edit: regarding softmounting the FC. would you softmount the pixhawk 2.1 Cube as well? eventhough it is vibration damped internally?

Arducopter is completely different from beta/race flight. They simply have a PID control loop. Ardu has EKF that is constantly trying to understand its position in space. there’s a lot more going on, and vibrations confuse it… It thinks it is moving. You really can’t compare them. Easiest things to try are to check the balance of your props and cover the barometer with foam.
Also, like I said, you have to be sure stabilize is working fine before you begin to try alt_hold and other automatic flight modes. One step at a time!!
If stab isn’t working it’s likely an issue w/ the flight controller.
It’s not a firmware issue, or everyone else would be having similar problems.

I have given up on the big expensive FC’s like the cube now that we support little light weight boards like the Kakute f7, so don’t have first hand experience, but I would imagine you don’t need to soft mount them… I bet a quick search would definitively answer that for you.

Hi Stefan

You need to calibrate your RC in mission planner. Your throttle out is either 0 or 100% - nothing in between - because of the wrong calibration. RC3 is throttle.
So everything should be ok with the FC and also the firmware it is only a miscalibration of your RC
By the way, the only flightmodes you set up is althold and sport, not stabilize mode. You should also configure them, so that you have stabilize, althold, acro, sport mode

RC1 is Ok:
RC1_MIN: 982
RC1_TRIM: 1499
RC1_MAX: 2006

RC2 is Ok:
RC2_MIN: 982
RC2_TRIM: 1493
RC2_MAX: 2006

RC3 is misconfigured:
RC3_MIN: 982
RC3_TRIM 982
RC3_MAX: 2006

RC4 is Ok:
RC4_MIN: 982
RC4_TRIM: 1494
RC4_MAX: 2006

RC5 is misconfigured:
RC5_MIN: 982
RC5_TRIM: 982
RC5_MAX: 2006

RC6 is misconfigured:
RC6_MIN: 982
RC6_TRIM: 982
RC6_MAX: 2006

RC7 and RC8 are Ok

Please give feedback after you done the calibration and your next flight



Good catch, Harald! It’s usually something simple.

And Stefan, if that fixes the issue, I should mention, the FC doesn’t HAVE to be soft mounted… That’s just a best practice suggestion. So if it works hard mounted, leave it as it is. But if you do have issues w/ it maintaining altitude, check your vibrations again.

Thanks wicked1 for your feedback.
Whether to softmount or not Stefan still can decide after analyzing the vibes in mission planner.

well that explains a lot! so it seems in my crashes the problem was that due to the misconfigured calibration the FC got 100% throttle input when there actually wasn’t? Am I right?
I actually calibrated the transmitter twice in mission planner. I do not know what I did wrong. I just re-ran the calibration process and see no change within the mission planner. All the min max values are the same as before? Is there any way I can test if the calibration is OK before I do my next flight?

In MP on the radio calibration screen it has a visual representation of the output. So check there. Slowly move the throttle up and down, and see if the green bar moves slowly up and down as well, or if it just jumps between high and low throttle.

Before rerunning the calibration I checked it. The values where moving with my stick commands correctly- no jumping between values. I then did the calibration again and saw no difference. It was just like before. When I move the throttle slowly from 0 to 100% the values change smoothly.

You can check it in the full parameter list.
The values should be around (+/-):
RCx_MIN: 990
RCx_TRIM: 1500
RCx_MAX: 2010


Be aware that the throttle stick has to be in the middle position before ending the calibration!

Finally you can unmount the props and throttle up in stabilize mode. The speed motors shouls then change accordingly the speed.

Doesn’t betaflight have a different rc control order? Taer, or something?

I gotta jump in here.

Soft mounting the FC is critical. Vibrations confuse AltHold. I have an H4 Alien 680mm with a Pixhawk 2.4.8 that would not hold altitude. The data flash log showed that the vertical Z axis was getting swamped with vibrations. The data flash log also showed that the #1 and #2 motors did not have the same RCOUT values as the #3 and #4 motors did.

As it turned out the vibrations were caused by a flaky ESC and motor misalignment (motor #3 was not exactly square with the frame). I replaced the ESC and tweaked motor #3. Z axis vibrations are acceptable and the aircraft behaves as it should.

I tried using and earlier version ArduCopter on an Omnibus F4 V3 and I really didn’t like it so I went back to using iNav (this is a VERY long thread).

RC3 trim has nothing to do with it. It is a faulty or not damped IMU.

Look at IMU.AccZ it went haywire and registered +10 – +25 m/s/s which interpreted by the EKF as acceleration towards the ground. So it gave full throttle to counteract. Look climbrate by baro and climbrate by EKF, (BARO.Crt and CTUN.Crt).

I don’t want to scorn the omnibus controller, but it is very common that cheap CN flight controllers are built from factory reject parts, I would not trust anything on them that has at least a little value.

Buy a kakute F7 AIO
It has soft mount I’m

It works great with ARDUCOPTER