OktoX flips on takeoff, pixhawk mounted backwards, checked everything

Hey Guys,

i try to get my oktoX in the air, its not my first ardupilot uav… but i cant find the problem, hope you can help me.
DroPix 2 https://drotek.com/shop/en/dropix/478-dropix-flight-controller.html
Here GNSS https://drones.altigator.com/here-gnss-gps-for-pixhawk-21-p-42426.html
DJI S1000 frame with arms mounted correctly for the pixhawk motor direction.

i have my dropix mounted with the front pointing backwards.

What i did:

Flashed copter octa 3.5.5 with MP 1.3.56
calibrated ACC
calibrated compass
calibrated RC

Checked ahrs orientation in mission planner hud. Follows my movements also the yaw.
MissionPlanner motor check works as shown above (A…B…C…), Motor directions are correct, Props are mounted the right way (please have a look at the image)

Tryed to take off. the okto is flipping and yawing wildly, looks like sensor orientation or motors are wrong.

I have two of those uavs, hardware is exactly the same, both act the same.

Link to configuration file and log of tying to take off:

funfact: i had a similar problem here and was never able to figure it out.

i would LOVE some advice what to do now! Hope you can help me out :wink:

Nice.Scary,but nice.

I’ve found this.
PARM, 246946846, SERVO7_FUNCTION, 10 -

Which ought to be set to 39 for motor 7
And which may explain the behaviour of CH 7 dropping out every few seconds.Or may not.It’s a de-sync though for sure.

Channel 3 is flatlining and the motor output isn’t exactly balanced across the set.

I’d stand a long,long way back trying to get that one off the ground.

I’ve heard that DJI ESCs can be a bit tricky with Arducopter but as I don’t have experience of using them I’ll leave that to someone who has suffered at their hands to comment.

This could run and run.It’s possible that resetting the above output channel will balance everything out but it looks a bit dodgy to me.I can’t put my finger on why though.Give it a try and report back.

Yeah.There’s something fishy going on with the motor outputs for sure.I just don’t know what.Like I say I have heard of DJI ESCs causing some headaches.Hopefully someone will spot this and come on in.

Motor 3 flatlines.It hardly picks up at all but motor 7 is cutting out in pulses,so it may not be apparent to the eye.Number three should be noticeably slower than the rest but it’s almost as if the copter is tilted over at take off and the motors are trying to compensate.I can’t see anything in the log that would explain that.All the PID loadouts are stock,so nothing to see there.It should take off with those.

It’s going to be hardware.I’d start at the ESCs and be asking around.After resetting the channel 7 out and trying again that is.Just hide behind something solid.:slightly_smiling_face:

I had no problem with these escs using min 1120 and max 1920. on motor test everything is smooth and fine.

.I can’t see anything in the log that would explain that.All the PID loadouts are stock,so nothing to see there.It should take off with those.

thats also all what i can see.

@Jagger First problem solved, thanks!
the motor dropout was caused because i set the “shutter” to servo 7 in mission planner. i thought this would be “rc in 7”.

no more problems at motor 7, but the okto still tryes to flip.

Looking at that log there appears to besome sort of disconnect between the throttle and motors but it’s not consistent.

On the first attempt here,with almost no throttle, the motors spin up a rather long way and they start late.On the next attempt the motors track the throttle input well,as does the third attempt.It’s possible that on those two tries taking the throttle to about three quarters briefly (called punching it) would have resulted in a take off - when the FC can take over and level things.Or a crash.The last attempt has de-syncs again and would have flipped for sure.They also responded late to the throttle input.They come after a crash check so could be corrupted or have needed a reboot to clear things up.

There is also the matter that the motor output drops as you arm,marked by the Stabilize flags.I don’t understand that bit at all but it looks weird.And possibly dangerous.

Without understanding the problem I’d be highly tempted to wipe the firmware and start again and including an ESC calibration (rather than setting the limits manually).

i agree, second and thrird attempt look good, with more trottle we would have had a takeoff.

hmmm i will wipe everything again tormorrow. set it up again and try. i will just push the trottle up… have some spare props :smiley:

1 Like

Yep.Sometimes you just have to bite the bullet.

Just enjoy the adrenalin hit. :grinning:

And hide behind a wall or bystander.:wink:

You’ve got folding props anyway.They can survive a bit of tumbling.

If it flies then an autotune or three is in order to set better PIDs but change your filter rates beforehand.Recommended for large propped copters like yours.


Uploaded the firmware again, did all the setup… again.

there goes another set of propellers :smiley:

i am quiet pissed now :stuck_out_tongue:

something is super fishy… i checked again, when i test motor B / 3 in mission planner… my fc is actually not using motor out 3…

i used the labels on the fc… for this try and did not stick to mission planner like last time.

im just super confused.

ok my connection now is:

A / 1 = physical motor out 1
B / 3 = physical motor out 6
C / 8 = physical motor out 4
D / 4 = physical motor out 7
E / 2 = physical motor out 3
F / 6 = physical motor out 8
G / 7 = physical motor out 2
H / 5 = physical motor out 5

ok :smiley: i was so pissed that i went to my basement grabbed some new propellers and put them on.

now i was following the “mission planner” output.

i got it off the ground ! the first time. BUT it was wildly spinning.
there goes the landing gear…

i stop now. there is no reason in breaking more stuff.


which flight mode are you using for takeoff (I assume you tried stabilize mode)?

I’ve had frustrating issues like this too a while back (not your exact problem) - in the end there’s not much you can do probably but eliminate one possible cause at a time, step by step, until it works…

In your case I can think of couple of things:

  • unusual (even though supported) orientation of FC (try changing it round maybe)
  • defective ESCs (maybe only some, try replacing them)
  • defective FC (maybe vibration induced, maybe try replace it)
  • negative influence of attached peripherals (unplug all accesories like GPS, SIK), trim it back to bare bone

Kind of systematically eliminate possible root causes, one by one… a bit expensive maybe… but you will get to it that way :slight_smile:

Don’t give up,

Hey Christian,

thanks for the ideas.
Sadly i did all that, except of the fc turn.
changed all escs.
changed the fc.
vibration should be not a problem, log is fine, and its isolated.
nothing is connected, rx and gps. thats it.

Tryed to logicaly exclude all factors/errors, from my perspective im done. I have been working around 4 years with ardupilot (rover, copter, planes, subs) and never had a problem like this :confused:

i will change the fc tomorrow to a pixhawk 2.1 in non reverse orientation.

This shows where the problem is.It’s probably a Frame Class/Frame Type thing.Sort it out by plugging the motors in correctly,so that the motor test works in a clockwise fashion as expected.Connected up like they are there’s not a chance of it flying.

EDIT: Just checked and the frame class and type are correct for the octo so it’s just down to physical wiring of the motors.The first two columns show which motor is where and the third column (physical motor out) shows they’re wired wrong except for motors 1 and 5.

Hey Jagger,
i am aware of that. but only when i wire it like that the motor test in MP is ok.
the last flight (with take off and wild spinn yaw) was done like that.

with the “correct” connection it flips immediately and wildly spinning.

i think in the first place we should find out why the wirering is not like in the wiki and written on the fc.

Pixhawk 2.1 installed in normal orientation.

flyes normal… as expected -.-
pfff one week…

thanks for your time guys!

Oh well.Don’t suppose you’ll be getting another Dropix then. :grimacing:

Sorry, I was being a bit slow on the uptake over motor numbering.It’s bloody weird for sure.All the servo numbers check out so it sounds like it’s internal to the FC.I’d take it apart and examine it with a large screwdriver. :kissing: