Servers by jDrones

Octo Flip during takeoff

Hi Guys,
This is my first try for a X8 , my drone is flipping in random direction during take off (Mostly front and left)
I tried adjusting AHRS TRIM X AND Y but still same.
Motor Numbers, props numbering all are ok
RC/Compass/ESC/Controller calibration done multiple times , result is same

My Build:
Tarot X8 Frame
Tarot 320 KV Motors
Tarot 1555 Props
Tattu 22000mah 6s lipo
M8N and M9N dual gps
Holybro Durandal FC
Flycolor 40A ESC

Log:
https://asmksa-my.sharepoint.com/:u:/g/personal/a_kamil_asm_net/ETnEIPBpc8lJlhlrq2dIJhMBGz-I5tSQf-MGzRB-L9kQGA?e=fySRql

You have Frame_CLASS 3 (Octo). You need 4 or OctoQuad if it’s an X8.

1 Like

Hi Dave,
Thanks for the response , this is the frame (Tarot TL8X000 X8 8 Aixs Umbrella Type Folding Multicopter Octocopter)
417iJbcMiML.AC

That’s not an X8 so you do have the right Frame Class. Did you test the motor order and direction with Mission Planners Motor Test? This is almost always the reason for flipping on take-off. And not to belabor the point but many have got this wrong even after stating they have “triple checked it”.

Yes Motor Numbering Checked multiple times with MP Motor test , running in correct order and sequence.
Props are also in correct order.
Im giving slow throttle to check if it flips or not , most of the time its tilting towards forward and left.
The strange thing is after adjusting AHRS TRIM_X and Y from MP to counter the tilt , sometimes it lifts off but i have to adjust the values by trial and error before each takeoff and most of the time even after adjusting values it tilts.

This is typically not done manually for any reason. A proper accelerometer calibration will sort that.

+1 for Daves suggestion of redoing the Accel calibrations, pay special attention to levelling the whole aircraft in every direction across the top of the motors/props then hit the Level Horizon button.
Then reboot and see if the HUD in Mission Planner is always working properly at each power-up, or is it showing tilted as soon as you power-up.

The accels are more and more wrong over time, if you are starting in level ground.


Maybe leave it powered up for a while, then reboot and test.

Check the BRD_IMUHEAT params, other similar era flight controllers use:
BRD_IMUHEAT_P 50
BRD_IMUHEAT_I 0.07
…but the defaults you have could be OK, I cant test it myself.

Thank you guys, i did re calibration today, i tried my best to level on each side (by balancing it against wall). double checked the props and motors and tightened the arms to ensure that are no vibrations.
, i also tuned the initial pid values (based on Shawn excel file the New Tuning Instructions Wiki Page) but still its leaning towards forward.
IMU heater values also changed.
On reboot the HUD shows that its leveled
At 40-50% throttle it wobbles and pitches down. as soon as it tries to pitch downwards i reduce the throttle.

Strange thing is , today i flashed px4 , it took off , no change in hardware or anything,
the only thing i did is flashed px4 , calibrated compass / accel , radio/esc (same way i was doing in arducopter) and on first try it took off.

i had a spare holybro pixhawk4 lying around , i replaced drundal with pixhawk 4 and it took off also on arducopter.

so maybe some issue with the arducopter support for Durandal?

Mag 3 is going VERY BAD with throttle (from you first log posted above)
I assume PX4 is just ignoring the internal compass.

It would be a really good test if you can load up Arducopter again and retest with that compass disabled:
COMPASS_USE3,0

Or even do the Compass/Motor calibration procedure - be careful, it could be dangerous.

EDIT: I think we didn’t check this earlier because it did seem like an Accel problem
Also try to use those updated IMU Heater settings and let’s see what a log file looks like
BRD_IMUHEAT_P 50
BRD_IMUHEAT_I 0.07

Following log for today test:
https://asmksa-my.sharepoint.com/:u:/g/personal/a_kamil_asm_net/EbFATzNIq19BvuUOetr8XsQB8x9ElBgwiBr8VFW7SievqA?e=f8kd3q
Re-calibrated everything before test
Internal compass disabled (IST8310) , only 2 external compasses are enabled (IST8310 and QMC5883L) , external compasses are with gps modules which are mounted on gps stands

Same behavior as before
P.S on px4 all three compasses were enabled but im not sure about priority


This log shows maximum commaded output and it’s not leaving the ground. What motors (you only say 320kV) and what’s the Take-off weight with that battery?

Test video: https://asmksa-my.sharepoint.com/:v:/g/personal/a_kamil_asm_net/EWsTYJd0vFpAnBZVhGWjLX8BSqxVRYzdx0bXKhwRvpGvzA?e=X0VZNd

i gave around 50% throttle and it was going nose down
Takeoff weight is around 7KG
Motors are:
Tarot 4114/320KV
Parameter:
Outer diameter: 46mm
Stator diameter: 41mm
Stator thickness: 14mm
Stator number: 24N
Magnet Poles: 22P
Wire diameter: 0.31mm
Motor KV: 320RPM/Volt
22.2V No-load current: 0.5Amps
Resistance: 126mз
Weight: 148g
Gear shaft diameter:)4.0 mm
Motor length: 32mm
Motor shaft length: 37mm
mot

Not sure what this is. It looks like you gave it full throttle here, Motors at max command. You don’t have current logging, that would help.

Can you be more specific about the ESC ? I remember having troubles with Tarot 4114 6 or 7 years ago. They only worked well with K-Force ESCs reprogrammed with BlHeli.

ESC Are : Flycolor 40A OPTO 2-6S ESC for Multirotors
Most probably the fimrware is SimonK.
Input Voltage:2-6S
Con. Current: 40A
Max. Current (10s): 50A
BEC: No
Dimension: 45 x 27 x 10mm
no other documentation i can find

One other thing i noticed when in Ardupilot , MOTOR_PWM_MIN and MAX is not updated after esc calibration , in PX4 its auto updated after ESC calibration to sepcific values like 1137(min) to 1927(max)
i tried setting them manually to 1000 (min) and 2000 (max) and do a calibration in ardupilot but nothing changed.
also one other thing is when i flashed px4 after ardupilot , no motors spin unless i do esc calibration even setting the pwm min and max didnt work (same case from px4 to ardupilot)

After RC calibration is done correctly and MOTOR_PWM_MIN and MAX are set to 0, then RC3 (throttle input) is used as the MIN and MAX for calibrating the ESCs.
It’s in the parameter info.

Shawn. there’s low-kV 22-pole motors running on 8-bit ESCs. Not reliable. I crashlanded a flat-8 in this configuration trying to capture sportscars burning tires because Paul Walker died a couple days before. So 2013, and probably on an APM 2.5 :smiley:
It wasn’t the octo’s first flight, obviously, so they kinda’ work, but I think I descended that day with 3 desynched motors and zero yaw authority.

Quick question (sort of noob question):
i have some spares 40a 6s blheli 32 esc’s lying around , would they work ?
They don’t have any added heatsink like the one currently installed and are quite small compared to the one installed

The modern ESCs are quite different to the ESCs from only a few years ago. Physical size is not as much of an indicator as it used to be.
In BLHELI ESC settings turn off Low RPM Power Protect and also Low Voltage Protection. Ensure your other voltage and current sensing if working correctly and accurate. You don’t want the ESCs deciding to shut down while the flight controller is still trying to fly and maintain stability.

The only real way to tell if they are going to work long term (more than 1 take off) is to put a motor, prop and ESC in a test jig of some sort and use MissionPlanner motor test or the BLHELI motor test to run the motor and prop for extended periods and try many high RPM/low RPM cycles.

@ThePara Yeah there’s plenty of cheap gear out there that probably should be illegal to sell these days :slight_smile:

Servers by jDrones