Object Avoidance with Bendy Ruler?

I’ve installed a SF40 on top of my quad to use for horizontal obstacle avoidance. I have it working with it displaying on the PRX page in Mission Planner. My question is how do i set it up to ignore objects that are within 1.2 meters of the sensor? Its currently seeing the forward props and i don’t want it to think those are obstacles.
I’m using 4.1.0 beta 6.




@rishabsingh3003 and I have discussed adding a PRX_MIN parameter but we haven’t done that yet. Until this is complete could you try using the PRX_IGN_ANGx and PRX_IGN_WIDx parameters to ignore the forward propellers?

Hi, thanks for the reply. If i ignored them that would blank out 90% of the fwd view. This is a large Ag Drone with 30inch props, they cover most of the view fwd and sideways. I can’t put the sensor below the quad, that is where all the water sprays.
Do you know when you might add a PRX_MIN param?

Its pretty easy to add now , Copter 4.1 onward, because of all the recent changes we have done. I’ll try and do it when I get the time, but no promises on when it will happen

Thank you both, I appreciate the assistance!!


I tried it in flight and it did what i feared it would. While in Loiter i activated the avoidance via a switch, it started to wobble a lot, looking like it was trying to avoid all the props it was seeing, so i quickly flipped the switch back. See file. I had to disable Bendy to fly the rest of the day in auto. I hope this helps any analysis you have to do. Thanks

FYI…this happened on the first hover flight of the log. Also, the lidar stopped displaying on the radar screen mid-way through the 3 flight and never came back on. I’m not sure why it just stopped working, maybe you can see something in the logs.

File name: “2021-07-31 15-38-21.bin 31 July with Proximity avoidance on.”


@Gromitvt10 nothing much we can do about the wobbles there till we add a minimum distance param, I think it is detecting the prop’s

It’s trying to avoid obstacles at 0.5 meters away constantly

Can´t you just physically raise the SF40, so that it “looks over” the props?

@rishabsingh3003, @rmackay9
Hi, any ideas when you might have that update complete? Thanks again for the assistance.

Hi, it is above the props. Looks like I’d have to raise it a lot higher for it not to see the props. Putting in a parameter to ignore returns within a certain radius makes more sense and would allow for cleaner designs.

@rishabsingh3003 @rmackay9
Hi, we’re you able to make any progress on this? Thanks.