NTRIP into Mission Planner?

I’ve been told I can get public NTRIP RTK data into Mission Planner. In my state Florida in the US, 40.121.5.206:10000 offers NTRIP data for all 4 GNSS systems. I tried to get NTRIP data in Mission Planner and it just gave me an error message. By the way, I don’t actually have a flight pack connected. If I can’t get Mission Planner to accept public NTRIP data, I won’t do the project. How do I connect to NTRIP data from the Florida site? I took a look at the 40.121.5.206:10000 and got a page of data back. The data from the Florida site looks like the following
STR;CMRP_NEAR;CMRP_NEAR;CMR+;;2;GPS+GLO;;;0.00;0.00;1;0;Leica GNSS Spider;none;B;Y;9600;

STR;RTCM3_NEAR;RTCM3_NEAR;RTCM 3;;2;GPS+GLO;;;0.00;0.00;1;0;Leica GNSS Spider;none;B;Y;9600;

STR;MSM4_NEAR;MSM4_NEAR;RTCM 3;;2;GPS+GLO+GAL+BDS;;;0.00;0.00;1;0;Leica GNSS Spider;none;B;Y;9600;

You need to use the right format for the Remote Host.
Mine is as follows putting in my User name and Password from our CORS services account.

http://user:password@148.149.0.87:10000/NETWORK_SOLUTION_RTCM3-GG

The Port/Mount info comes from something like this (for us in Michigan)
Port/Mountpoint

The Simulator in Mission Planner will work to test it. Of course it needs an Internet connection.

Try this:
http://user:password@40.121.5.206:10000/RTCM3_Near

No signon or password required for the Florida NTRIP system. I got the data just by entering the IP address and port in the browser.

When I just put in 40.121.5.206:10000, I get the following error


I truly wish I could copy the error message into this note. It says: " Error Connecting
if using com0com please rename the ports to COM??
System. UriFormatException: Invalid URI: The URI scheme is not valid
…"
I have no idea what these error messages mean. Is the error trying to get the NTRIP data from the internet or in passing it to the flight controller? I don’t have a FC connected. I’m using simulator only. How do I know if it is getting the NTRIP data from the internet?

When I put your format into MP, it also says “System.Exception: Bad ntrip Responce.” That line is not there when I use the raw 40.121.5.206:10000. If I just enter 40.121.5.206:10000 in the browser URL, I get a whole page of what looks like valid ntrip data. If I apprend “/RTCM3_Near”, I get “this page isn’t working” from the browser. So I’m reaching and wondering if MP is getting the right ntrip response. Just not passing it to the FC? And the error message refers to the FP interface?!? Maybe?!? How would I verify that its getting the right data?

What you’re seeing on the base URL (no mountpoint) is the caster table. It’s not correction data, just a raw text list of mountpoints and their specs.

401 is “not authorized.” You must register an account to gain access.

It will look like this (my connection) with the nearest (in my case) station shown:
Ntrip

Wow. Guys!!! Thanks so much!! I have learned a lot. I’ll try again and let you know… UPDATE: I did register, got my ntrip user name and pw and product. I used the format http://user:pw@40.121.5.206:10000/rtcm3_Near and tried it. Obviously I’m a lot further than I was. I am now registered, have understand the difference between the caster, mount point, etc. However, it still says not authorized. And a direct insertion of that line in the browser gives a “not working” message. I wonder if it needs time to register me, and perhaps I should wait overnight? Anyway, making progress. At least I am in the ballpark and know what to see in MP when it is working…

you are soo close. There are a few ntrip casters (?) that you can connect to that dont require a user/pwd and will fire up in Mission Planner. I’d post mine, but its down for a few weeks currently.
The following was useful for me http://rtk2go.com:2101/

Edit:Update - just use these remote ones to test MP/Ntrip traffic and connection strings - accuracy falls off pretty quickly with distance. I forget the rate, but a station 20km away is marginal for lawnmowing precision, noticably poor.

The fact that Florida offers access to survey grade, sponsored correction sources pretty much negates the uncertainty of the availability and accuracy of any given RTK2Go mount point. If you have access to the state sponsored network, I highly recommend using it.

There is a similar state-run service where I live, but it is only available through professional/govt contract, so I am unable to leverage it for personal use.

NOAA does make my locale’s correction data available as a historical archive, so I can use PPK (post processed kinematics) in lieu of a survey-in. But it is not accessible in real time without an account I cannot create.

https://geodesy.noaa.gov/CORS/

2 Likes

Thanks for the discourse, guys. Please hang in there. Hopefully if we keep it going, I’ll get it running. The nearest hard survey point of the Florida System (called FPRN) is 8km away from me at a small local airport. It easily gave me a private signon for free. Now just trying to get connected… So I tried again just now and no joy. The FAQ says it takes 24-48 hours for the registration to allow access. Must be an offline program that runs to register your rover. I wonder if the Florida system needs a different format for the request–as of now, no indication either way. They have tons of products. RTCM3-near is one of them. They also have a more localized product for my “District”, which is several counties , perhaps a diameter of 100 miles, with a different port number. So several things to try, but will wait another day to see if it registers.

If you are using the Simulator place the home position in proximity to where you are if it’s not already.

I have plenty of options here also but “-nearest” (for MI CORS) always works.

Thanks. I will be doing a rover and put home in my back yard. Still no joy in getting the ntrip data. I’ll wait the full 48 hours and try again. FPRN information doesn’t actually detail the format of the command to get the NTRIP data, so I’m using the format you all gave me and is in the MP.

If you continue to have trouble with feeding the NTRIP into MissionPlanner -

You can use RTKNAVI.exe from the RTKLIB suite - Releases · rtklibexplorer/RTKLIB · GitHub and configure it for ONE Rover Input that is the NTRIP server.

It’ll just plot the NTRIP server’s location, but you’ll be able to see the RTCM traffic going by, including real time satellite coverage and signal strengths and so forth.

It will confirm you do (or don’t) have the right definition for the NTRIP URL to put into Mission Planner.

Once you have the right details, transfer them over.

(Then, later, when you want to verify your new RTK GPS is working, you may end up using some of the RTKLIB suite while tesitng things out, to rule out problems with the flight controller and wiring)

For RTK2Go, here’s what works:

http://user-at-email.com:none@rtk2go.com:2101/MOUNTPOINT

  • Replace the email address with your username. If it is an email address, use the -at- format in place of the @ symbol.
  • Replace none with your password.
  • Replace MOUNTPOINT with RTCM3_Near or whatever mount point you were given to access by FPRN.

Of note, since RTK2Go only requires a valid email address, you can actually use “none” for the password (it is their recommended connection string). FPRN almost certainly requires a valid username and password to be supplied.

Here is what I submitted:
http://SailorKNTRIP:password@40.121.5.206:10000/RTCM3_NEAR
where “password” is my real password. “SailorKNTRIP” is the rover name designated on my registration. 10000 is the port and RTCM3_NEAR is one of the casters available. No joy. I do get a list of casters if I leave out the “RTCM3_NEAR” at the end.

I do have one other question. I sent it to FPRN for clarification. Apparently there are “products” to subscribe to. I thought that FPRN is free. The products appear to require subscriptions and at the end, it says “actual price will be billed”. The account setup required a company to be specified. Even though I entered “private individual” as the type of user. I might have to actually subscribe, but am reluctant to get sent a bill for the subscription, esp when the price is not specified. No where on the subscription page does it actually say its free.
The possible subscriptions are “NAD83, NAD83 GNSS Real Time Corrections”, “Rinex 3”, “Coordinate Computations”, “V Rinex”, and “GIS Corrections”. I wonder if I have to subscribe and if it is free anyway? I am such a newbee at this and thrashing around. I sent an email to the FPRN administrator and hopefully will get an answer. That may be the issue?

Look what I got!!! MP is working!!! Indeed, I needed to set up subscriptions and it was free!!! Thanks for all the help!!!

2 Likes

I knew we were on the right track, and NTRIP is fairly standardized, so we had to be close!

Glad you got it working.

Thank you and Dave so much!!! BTW, is RTK2GO free also? I have a friend in Georgia trying to do the same project as I am.