Not able to simulate flight in MP

I am on Mission Planner 1.3.79. I have reinstalled MP after having problems performing a simple simulated flight. Problems persists. Purpose of the simulation is to get some practice with flight planning.

What I experience is this:

  • Simulation complains about the file cyggcc_s-seh-1.dll missing.
    Solution: Copied the file from C:\cygwin64\bin into C:\Users\user\Documents\Mission Planner\sitl . Download and connect to the simulation was possible after that.
  • Dowloaded simulation via SIMULATION->plane->Latest(Dev)
  • The plane appears on the map and starts to move immediately
  • I generate a plan and Write it. That seems to work, but when I move to the Data tab, the plane drags the home point with it.
  • The plane won’t arm because of 3D accel calibration needed.
  • On inspection, the folder C:\Users\user\Documents\Mission Planner\sitl\default_params is empty. Should I find a parameter file there?

Is the MP simulation broken in some way, or maybe I am doing something wrong?

Thanks, Helge.

You should be able to run a Simulated flight with default parameters. Load Plane and Reset To Default from the Full Parameter list and try again.

Thanks for the reply.
I tried that, no difference in performance. Also I am still puzzled about the missing dll file and the default_params folder still being empty

Stick this one in it:
plane.parm (1.7 KB)

Update to latest Beta, maybe it will fix it.

Fantastic! It works now, thank you very much for your help. Although I did not update MP, still on 1.3.79.

I’ll remember to keep the .parm and .dll file in case they are not automatically copied after a fresh install of MP. A little puzzled about that though, but very grateful for the help!


1 Like