Not able to connect from Mission Planner using 3DR telemetry

Hi everyone,

I’m trying to set up a remote connection from Mission Planner to my Orange Cube wing (Plane v.4.4) using Holybro 915 telemetry.
I press “Connect” in Mission Planner, but after 30 seconds of waiting for the timeout, I receive the error “No Heartbeat packets received”
Both radio modules appear to be configured correctly, I am able to get the settings for the ground and air modules through the “SIK radio” menu in the mission planner (both modules have a green LED constantly lit, also red LED on both modules also blink when you click on “Load Settings” in Sik radio menu.

I tried connecting to the telem1 and telem2 ports - there is no difference. at the same time, other peripherals (like micro osd or elrs radio) work correctly on these ports.
SERIAL1 and SERIAL2 settings are standard, configured for 57600 baud rate and Mavlink protocol.
Radio wiring seems to be matching with telem1 port in Orange Cube docs.

Do you have ideas what can be wrong and how can I connect? Attaching screenshots with the errors and settings.
Thank you in advance.

I also tried to connect to QGroundControl same way - and it’s not working there too.
I also tried another radio (holybro 915 and fpv telemetry 433)

[D] at D:\a\qgroundcontrol\qgroundcontrol\src\comm\ - “allocateMavlinkChannel 4”
[D] at D:\a\qgroundcontrol\qgroundcontrol\src\comm\ - “open failed “Access is denied.” QSerialPort::PermissionError “sik2” autconnect: true”
[D] at D:\a\qgroundcontrol\qgroundcontrol\src\comm\ - “freeMavlinkChannel 4”

Please check whether TX / RX are connected crosswise to RX / TX on the Telem1 port. Also check whether this is the case with CTS / RTS.

Just using a simple 3 wire cable Tx/Rx/Gnd has always worked for me.
Just make sure you set the firmware to Xon/Xoff.

The other faint possibility might be the antenna.
Some of the cheaper chinesium products have BAD antennas that just don’t work.
Swapped them out with known good ones and some problems just go away, especially signal issues.

Thanks for the idea
Yes, TX and RX were cross-connected from the beginning. But the original wiring was connecting CTS to CTS, RTS to RTS (If I can trust the engraving on the module).
When I tried to cross-connect them - the air module stopped working at all (no green LED, solid red LED showing like it’s in bootloader mode).
So I had to revert it. I also tried without RTS/CTS pins at all - not working as well.

I also re-flashed to the newest version of both modules, and enabled RTS CTS option in sik radio menu.

Thank you. I tried to remove RTS&CTS pins - it didn’t help.
But I didn’t understand your comment about Xon/Xoff in the firmware. What option is it, and where can I change it?