Servers by jDrones

Nose down dive with throttle up on RTL

arduplane
rtl

(Kyomo Jung) #1

Hi,

My plane is nose down diving with throttle up whenever on RTL mode.

I couldn’t find the reason from the log.

Anyone who can give me a clue why she is diving?

Log
https://drive.google.com/file/d/1oCscxWFLUcftHp65VYmUBP3gpEXnCcVr/view?usp=sharing


(tridge) #2

you need to get your plane flying well in FBWA mode before you fly in AUTO.
Please also enable the normal LOG_BITMASK values. Your log is missing lots of standard log messages.
Cheers, Tridge


(Kyomo Jung) #3

Thanks Tridge.

I’ll fly again soon with rich log value and revisit here ^^


(wkf94025) #4

If you have an airspeed sensor on board and enabled, check logged airspeed vs ground speed. If airspeed pitot is blocked, or otherwise reporting low, autopilot will dive to gain speed if it is relying on bad/low data from airspeed sensor. Been there, done that.

Kelly


(Kyomo Jung) #5

Hi Tridge

I tried it again with FBWA and felt nothing wrong but in RTL, it couldn’t keep alt.

Attached you can find rich log value.

Looking forward to any clue from you ^^;

bin : https://drive.google.com/file/d/1oLfM05l3pdb5r8ypoQGrGIdx9NejCMfE/view?usp=sharing
tlog : https://drive.google.com/file/d/1oDaSp6XF3KfeS93sGAYcGR5Gd94A-XPZ/view?usp=sharing
param : https://drive.google.com/file/d/1oD-B-5J4IsCp0nYNU8wPn4fFUTe96O0E/view?usp=sharing


(Kyomo Jung) #6

Thanks wkf94025,

Airspeed sensor is equipped but ARSPD_USE = 0.

Appreciated if you look through the attached log ^^;


(Andre-K) #7

it does not seems to be tuned very well, pitch is very slow.