No way to make relay trigger works!


I’m trying to set a camera shutter with relay on a Holybro Pixhawk 4 on Arducopter 4.0.3.

First step, I’m trying to check relay pin works.
My motors are plug to IO Output, and I connect the relay on the first pin of FMU output on PM-07 power board.

My configuration is :

  • RELAY_PIN = 50 //AUX1
  • SERVO9_OPT = 10 //Camera trigger
  • CAM_TRIGG_TYPE=1 //Relay
  • CAM_RELAY_ON=1 //High
  • RC9_OPTION=9 //Camera Trigger

When I activate the RC9 channel on the transmitter nothing happens. Same result when I try to send a camera trigger now otpion with Mission Planner. And again same result when I activate Relay directly in mission planner.

I try all the pins and all relay configuration, still nothing happens when I try to activate Relay!

What’s wrong? Is there another option to activate relais? Or it other pins?

BRD_PWM_COUNT you would need 0 I think

Thank you very much… That was my problem.

In fact I tried before to post my question.
But my tests didn’t work because when we activate camera trigger to relay (CAM_TRIGG_TYPE=1 //Relay) the function in mission planner to make relay HIGH/LOW doesn’t work.

Thanks a lot!

This option is not available now!

I am still unable to trigger a 5V single channel relay module from any of the AUX ports.

Any help would be most very useful.

The documentation needs an update to make this clearer. There is actually a note in the Relay section but it’s easy to miss.
The new way is:
changes that output (AUX6 in this case) to be GPIO

1 Like

Let me check it today and update you about it here!

Thank you very much for the immediate reply.