Servers by jDrones

No USB Connection with latest build

(Stefan Moshammer) #1

Hello!
Since my Here 2 causes some weird GPS problems with “failing configuration checks” I want to reinstall the rc3 bootloader update and also switch the GPS to CAN mode using the manual found in another thread. easy peasy - at least I thought.

Prior I was running arducopter 3.6.9 stable on my Cube Black and expect the GPS error everything worked flawlessly.
In both manuals (rc3 update and CAN mode switch) it is needed to install the latest build/arducopter master. I downloaded the build from this link provided in the PDF manual for the bootloader update: http://firmware.ardupilot.org/Copter/latest/CubeBlack/arducopter.apj

I then opend up missionplanner and installed the firmware via the load firmware button. When the update was done the message with the “click OK when the tones are finished” (can’t remember the exact message but you probably know what I mean.) I was waiting and waiting but those tones never appeared. After like 10 minutes I decided to disconnect the Cube to reboot it. I then plugged it back in and tried connecting to it with mission planner. However I was not able to connect the Cube. The COM port is selected and it just does not connect!

Therefore I started digging for the problem. I reinstalled mission planner (currently running 1.3.68 build 1.3.7105.26478).
I reinstalled stable 3.6.9 - everything works fine, I can connect after installing the firmware. also the tones form the buzzer appeared
I reinstalled the latest master FW - same as before… no luck I can’t connect.

As everything works fine when running 3.6.9 I can therefore conclude that whether my laptop acts weird nor the USB cable or connector on the Cube is faulty.

Whats your best guesses? I really want to go fly again :frowning:

(Stefan Moshammer) #2

I fixed it. Turned out that the firmware from the firmware website did not work. I remembered that I downloaded the 3.7dev a whie ago on my desktop. flashed this firmware now everything works fine.