"No such mode" error

Hi All,

I am working on a quadcopter equipped with Micro Pix board. I set it up as usual, with the latest firmware and encountered a problem.

My normal setup for flight modes is this:

1: Stab
2: sport
3: Alt hold
4: Loiter/autotune (if required)
5: Pos hold
6: RTL

When I switch to “Sport” mode, I can hear the error buzzer tone and in the OSD or in the GCS there is a “No such mode” error message. Other modes are working fine, at least there is no error message when I switch them.

If I downgrade to the firmware Copter 3.4.6 V2 (Stable_3.4.6 from the Firmware page), “Sport” mode is OK and working… But, in that firmware I can not see the “Servo” parameters, and the servos on output 6,7,8 are not working…

I have searched the net for this kind of error, but I have not found anything…

Thank you for your help in advance!

it is happened to me, i lost some parameters.
manually download the firmware from the ardupilot firmware directory help me. and install it using Load Local Firmware in Mission Planner.
maybe you can try this method.

Thank you the advice! Actualy, the downgrade was done with both methods (online and pre-downloaded firmware flashing), and the results were the same, no SERVO_ parameters. I have tried the AC 3.3.3 version as well, same result.

Anyway, now the latest seems OK, but I would like to use the Sport mode, but, according to my FC, it is not existing… I have tried to set it in multiple GCS (PC, Android), also in the GUI and as a parameter set (FLTMODE= 13, if I recall well), but when I activate it, the reaction is ”No such mode„. …

Any idea, please?

I’ve just tested master and 3.6.7 - both allow me to shift into sport mode
without issue.

Please provide a specific git hash which is failing for you (it’s in the
text which gets spat out when you first connect to a vehicle / explicitly
fetch parameters)


Hi Peter,

Thank you for your help in advance! I will get the hash as soon as I get back to my copter!

I did the firmware update with the latest MP online, so I thought that the system would flash the latest, most compatible firmware to my board. There was no error indicated during the process, and other functions seem to be in working order.



So, hete are the data the FC sent back on connect:

ArduCopter V3.6.7 (38b8af17)

ChibiOS: d2030d88

fmuv2: 004E0030 31355117 35333436

ublox 1 HW 00080000 SW: 2.01 (75331)

I hope, this help! I have just landed, I have flown two ~6000mAh batteries, approx 10 min each. Everything went good so far, beside the Sport mode, and, strangly, the landing detection is not working also, after landing in assisted mode (AltHold), I am not able to disarm, the motors are spinning up in every ~5 seconds, if I switch to Stabilize mode, motors are slowing down normally and disarm is possible. There is sonar mounted to the craft, as I know it is working normally.

I suspect the issue is that Sport mode is not available in the v2 versions of the firmware for Pixhawk boards. if the -v3 version of the firmware is loaded Sport mode will probably re-appear.

I have to ask though, are you really keen on Sport mode? It’s very rarely used - so rarely used that I was planning to deprecate it. Sport mode is similar to Acro mode except the pilot controls the climb rate instead of directly controlling the throttle. Basically it’s a mix between Acro and AltHold. Most users seem to prefer pure Acro or pure AltHold.


Sorry for the late reply! Thank you for the info, I also was suspicious about that the v2 fw version is not supporting the Sport mode. Actually, currently I am not enough good to fly in Acro mode with a gimbal and a GoPro on board, so I have chosen the Sport mode as a dynamic but still a little assisted flight mode. So now, I will change the tilt limit parameters of the AltHold mode, to be able to fly a little bit more aggressive than now. By the way, is it possible to assign two different sets of tilt limits to one flight mode? It would solve the problem completely!