No stick response on IMX6

I have been working with an IMX6 on a Pixhawk 2.1 octoquad
everything was humming along, but the escs did not seem right.
These are CC escs so nothing new with getting them to calibrate
But I must say the new esc calibration in Mission Planner is pretty dang easy

Long story short, somewhere along the way it lost radio calibration
I reset the IMX6 and Solo Controller, repaired and tried again… nothing
I took that controller and paired it to a solo and it works fine
Took the controller off the known good solo and paired it to the IMX6 on the DIY, same result no stick response in the radio calibration

It is almost like it is not bound

But it connects and I can even arm it with the fly button
Just no output from the sticks

Any Idea?

Hi Tim, how have you been progressing with the IMX6?
I just received a couple and am going to hook them up to a Cube, as you have done.
Searched extensively for ANY documentation on the IMX6 but have found none to date.

Did you ever get it working?
Where did you find the pinouts for the IMX6?

Have you tried installing the Open Solo stack?

1 Like

It is possible that the FMUV3 with the Solo GImbal code etc is running out of memory in some situations. Since most doing this kind of build really don’t need the Solo Gimbal code just use the FMUV2 where the Solo gimbal code was removed to make more room. It worked to allow me to cal my Solo Controller sticks.

1 Like