No servo output

Hi. I am new to arducopter. I have a set of 4 racerstar and another set of 4 simonk 30a escs. I am able to calibrate the escs (all at once) successfully (using any set at a time). I can also test the servo motor from optional hardware settings in mission planner. but when i arm the copter I am unable to get any servo output. this has wasted my 2 days. any help will be appreciated. thank you

What mode are you trying to arm in?
Do you have mot_spin_arm enabled?
Do you have safety switch enabled?

1 Like

thank you @james_pattison for your time.

  1. I try to arm it in stabalize mode ( mode 1 providing 800 on transmitter )
    ( i have set “stabalize” in mission planner flight mode 1 too)
  2. mot_spin_arm is enabled
  3. safety switch is enabled ( we also tried disabling this by brd_safteyenable)

It could be that your transmitter isn’t sending the right values to arm.
If you have telemetry radios, take the props off, and try arming via Missionplanner.
If it doesn’t arm, note down what Missionplanner displays.
If it does arm, you probably need to sort out your RC calibration or the Throttle Min.

1.I can arm the copter by rc as well as mission planner. but when i arm the copter it is disarmed automatically after 10 seconds (both through MP and RC). RC calibrations seems fine as i can switch between 6 modes and ch1,ch2,ch3,ch4 can provide values between 1100 to 2000. what do yo mean by throttle min settings?

  1. and mot_spin_arm =1 right? it was 0 by default

If you don’t take off it authomatically disarm after few seconds.


@anon67614380 this is the issue. Even though i provide throttle from the RC There is no servo output after arming

thanku @james_pattison the issue was resolved by setting