Servers by jDrones

No Heartbeat APM 2.5

3 years ago I purchased an APM 2.6 board, but only got up the courage to solder the input-output pins to the board this week. Loaded Mission Planner, connected the board by USB and downloaded the firmware. Received a warning that the 2.6 was discontinued which indicated to me that the program was communicating with the board and could tell what it was. The firmware installation ran, red light flashed on the board, and the verification routine appeared to run normally (no error messages). The next step, connecting so that I could complete the setup failed. After dozens of attempts with various USB cords, different USB ports, and two different Win10 laptops, I can NOT get connected ~ it always times out and tells me is could not detect any heartbeat packages. I do not understand how it can be connected to transfer the firmware, but then cannot connect to do anything else. Is the board defective/dead??? Any help or suggestions would be much appreciated.

The latest firmware version(s) (3.7.x or 3.8?) are not supported on the APM 2.6, as the warning suggested. Try loading the last compatible version. I believe it’s 3.3.0. (http://ardupilot.org/copter/docs/common-apm25-and-26-overview.html)

Loading the firmware and communicating via mavlink happen a bit differently: I’ve had this happen before, where I could do one but not the other. The first two things to make sure you have right are the com port and baudrate (115200), in the top right corner of Mission Planner.

1 Like

with APM, 3.2.1 is the final firmware version.
In Mission Planner, you can try to load 3.5.1 but it will only load the final rev 3.2.1.

Also, with 3.2.1, you need custom firmware.
Follow this guy for setup:

My previous post had assumed he was working with ArduPlane, while @pmshop is describing information for ArduCopter. I’m not sure which @rickjnav is interested in

That custom firmware is for the cx20/quanum nova, which has a modified apm in it. Not sure it will help here.

I’m trying to get ArduPlane working.

I’ve done that…the firmware download program is smart enough to recognize that it is an old APM board and automatically loads the latest compatible version. Once that is done, and apparently verified successfully, I can’t get is to connect with Mission Planner due to the "heart beat detect failure’. I’ve tried on two different laptops (both running Win10) with the same result. In both cases, the COM port does not seem to know what is plugged into the USB port, it just shows “COM4” or “COM5”. I do have the baud rate at 115200. How about ‘parity’ and the other com port settings?
I tried to use an even older laptop with Win XP, but could not install Mission Planner. It required Netframe 4.0, and even after I was able to get that installed properly, the Mission Planner installation program insisted that it wasn’t there.

Seeing just “COM4” or “COM5” is normal, it’s not a sign that the computer “doesn’t know” what it’s connected to.

An idea: Are you able to connect to other ArduPilot devices using those laptops? That would show it’s not some issue with Windows drivers or the computer’s USB ability.

When I go to Device Manager and select the Properties for the COM port it
does show there’s an APM2650 connected, so that part seems to be working
OK. The fact that the firmware download functions and verifies would
indicate to me that communications between the computer and the board are
working OK, but no end of trying will get past the heartbeat error.

At the moment I do not have any other Ardupilot hardware to try. I am
expecting an APM 2.8 board soon, and this exasperation drove me to order a
Pixhawk board too.I sure hope that I have more luck with the latter. I
can’t believe that I’m the only one that has encountered this problem and
am very surprised to find that there is no ‘standard solution’ waiting to
be applied. I imagined that thousands of people are using these older APM
boards every day.

My Pixhawk arrived, but far from being the salvation to my problems, it has
just given me a new batch of frustrating problems to deal with. I have been
able to get connected to it and go through the initial setup, but it is a
long way from being able to use, and the user manual is woefully inadequate
for someone who is just starting, especially when things don’t work like
clockwork.

What do two solid amber lights mean? That’s not an option mentioned in the
manual. What does “Bad Compass Health” mean, and how do you fix it? Why
don’t the available Flight Modes in the drop=down lists include all of the
flight modes in the user manual? and so on and so forth. I consider myself
pretty computer literate, but I’m starting to think this ardu-pilot stuff
is junk!

Rick

I encourage you to be patient while you’re learning. Many folks have contributed (and still contribute!) lots of effort to ArduPilot, and you won’t encourage them to help you by suggesting their project may be “junk.”

Maybe you missed this page of the manual? http://ardupilot.org/plane/docs/common-leds-pixhawk.html?highlight=led

It means that the compass sensor, and it’s corresponding code, are not reporting a “healthy” status. This can be caused by a variety of things. When I see this error, I first check the “status” tab on Mission Planner (while connected) to see which magnetometer measurements are being received (and therefore updated in the status tab) and which are not, indicating a faulty sensor or a faulty connection cable. If all magnetometers appear to be generating data, I’d then try (or re-try) the compass calibration and verify that’s working well for all compasses which are being used by the autopilot. After successful calibrations with reasonably low offsets, I’d reboot the PixHawk and see if the error is gone. If not, I’d consider posting to these forums again at that point.

The user manual has most things right, but cannot reflect all versions of ArduPilot (are you using ArduPlane?) nor is it always completely up to date. If you have a question about what modes do what, and it’s not covered in the documentation, that’s a good question for these forums.

I hope you’ll have patience, read the documentation carefully, and ask (politely) here for help when something else inevitably doesn’t work as you’d expect.

Sorry I let my frustrations get the better of me. You’re quite right, these
autopilots can do some really amazing stuff…that’s why I spent the money
in the first place. It just hasn’t worked out as easy as the YouTube videos
made it appear so I just have to take the time and learn, step by step.
Please bear with me.

No problem! I’ve been very frustrated with ArduPilot at times too, as I suspect many others here have as well :smile:

I’ve only hit one flight controller with a hammer. :grin:

I’ve got three APM 2.52s ( and a 2.6) in the draw with no method of communicating with them.One gives the no heartbeat message and the other two just do not exist as far as any computer I’ve got is concerned.Pretty sure it’s corrupt bootloaders and I have no way of hacking into them.So I went to Pixhawks.

Installing and tweaking the latest firmware is a challenge even for some of us with a few years experience.The code has grown so far and so fast recently that the documentation cannot keep up.There are now over 700 parameters in play and that takes some learning.

Having said that there should be enough info posted in the wiki to get it up in the air and nicely tuned.Got any pictures of your rig.That sometimes helps.

https://drive.google.com/open?id=0B_J_MtgEPdyhZmJrOTdLRjJqYlkyV2tBbFZHUnV4QjNBQXpFH
This is a pic of my new Pixhawk set up for calibration and system check. You can see there are two solid amber lights at the top…a condition not described in the manual.
The big bright light at bottom-centre is flashing but it is hard to distinguish just what color it is -could be amber or combination of red and green??? (No, I’m not color blind, it is just very bright and hard to pick out one particular hue.)

So what is happening? Is the board defective? I was able to upload the firmware to it and get connected with Mission Planner and go through compass calibration etc.

That link give a 404 Rick.

The big LED is the main messaging one but there’s no way for us to know what’s what without at least a video of the behaviour and logs would help too.Can’t say what you’re seeing because I’m not seeing it.Can’t say if the board is defective without more info.As a guess,seeing as how it’s taken the firmwre and calibrations,it’s working fine.It’s just getting to know the system and what it requires is all.And as I said that can be challenging for those of us with experience.

I’ve given up on the Pixhawk for the time being because I received the APM 2.8 I’d ordered earlier. It seems to be working OK except for the Flight Modes. Under Radio Calibration the 3-position switch commands the appropriate changes on Channel 5, but when I go to the Flight Modes tab moving the switch makes no difference to the display, and even if it did, the flight mode options are weird: Initialising, QStablize, QHover, QLoiter, QLand, and QRTL. I’m using ArduPlane, not ArduCopter. I can’t find anything in the user guides that offers any help on this.

You shouldn’t be able to get those flight modes on an APM 2.8, but I guess they might appear in the dropdown. They’re the ArduPlane VTOL modes. You should just be able to select the modes you want from the dropdown.

Did you happen to load a parameter file from a pixhawk?

Hi James, Thanks for the explanation on what the Q- modes of flight are. Although I successfully loaded the firmware for the APM board, those are the ONLY flight modes that appear on the drop-down list.

I do have a Pixhawk, (which I can’t get to work), so I suppose it’s possible that the system mistakenly loaded a Pixhawk parameter list, although I have no idea how to do that. I have been using the Mission Planner’s wizard for Initial Setup, so I’m at a loss to explain what is going on.

I do not understand why the “Radio Setup” screen recognises the 3-position switch on Ch5, but when I go to the Flight Modes screen the switch has no effect whatsoever. What Input on the APM board should the 3-position switch channel from the Receiver be connected to???

Any and all help greatly appreciated.

Servers by jDrones