No GPS, Hex Cube Orange

Any and all help is appreciated. I am building a zero-turn autonomous mower using a standard Ardupilot rover V4.2.3 firmware install. Flight Controller is Hex Cube Orange PX4. GPS (GNSS) is Sparkfun Surveyor that uses a U-Blox ZED F9P receiver. Mission Planner is the flight control software. GPS ZED F9P signal is received by a PC (laptop computer) through a USB port without a problem and displayed through mission planner and U-Center. The configuration out of the GPS ZED F9P receiver is u-blox, NMEA is the standard output for Sparkfun but the configuration out has been changed to u-blox so that the flight controller can understand. In Mission Planner a baud rate of 38400 has been applied to Serial3_baud with Serial3_option=0 and Serial3_Protocol=5 (GPS). The 38400 baud rate has also been applied to the UART1 output for the GPS ZED F9P. Attached are my latest Mission Planner configuration parameters and the latest U-blox configuration parameters.
Things that are weird to me. Note: I am a Mechanical Engineer and do not have significant knowledge about electronics even though I have designed HVAC control systems throughout my career, so go gentle.
I have been able to get devices connected to the 14 pwm/servo output pin sets (8 + 6). I understand these come out of the Failsafe Co-processor not the Main Processor (FCU). I only thing that I’ve gotten to work out of the FCU is the Safety Button, Safety LED on GPS1 pins 6 and 7 along with USB port. I notice that the power for each UART port seems ok at 5V and Tx pins have 3.3 volts. I do not know of another way of determining if the FMU is working, but do not see any other signs other that I have plugged a lot of sensors in that give no feedback.
The hardware ID list in mission planner setup does not show the GPS device. The UART1 out of the GPS ZED F9P receiver goes to the GPS1 input of the Hex Cube Orange PX4 (I believe GPS1 is also labeled Serial3, ttyS3, UART4 throughout different places and documents). I have checked both through voltage outputs and product data sheets that Tx goes to Rx and Rx goes to Tx. There is confusion for the GPS1 port for the PX4 in the data sheets, seems that at some point the Tx and Rx pins changed places. Just to be sure if I have swapped pins to try to make it work, no avail. Have also tried to use the GPS2 port (I believe GPS2 is also labeled Serial6, ttyS6, UART8 throughout different places and documents) without avail.
I notice that I get 3.3v out of the UART Tx and Rx ports of the GPS ZED F9P receiver when it is not connected to the Flight Controller. Should this be? Seems as the GPS ZED F9P receiver should receive it’s Rx voltage from the Flight controllers TX signal.
I have also tried to connect the GPS ZED F9P receiver to the Flight controller through their I2C ports with reconfiguration in both mission planner and Ublox. No avail. The pictures show a temporary wire harness for the I2C connection.


Maybe it’s just the photo but I don’t see a ground wire hooked up to GPS1.

This post has the pinout for the cube carrier board. Pixhawk 2.1 pinout doc need to be on the Pixhawk 2.1 page

Great catch on that missing ground. That could be an issue!

Thanks for the response. I added a new photo, I had disconnected the GPS wires in the original photo for testing, you are seeing the button and LED wires. last night I found a hairline crack in the SD card that came with the flight controller. I have replaced the SD card and the flight controllers start up sound changed significantly. Seems unusual that an SD card would be damaged that was in the SD card slot when shipped. There went months of trying to figure out why the flight controller was acting as it was.

I have not solved the No GPS signal. In U-blox_congifuration_msg(messages), What is the message to be sent out of the GPS ZED F9P receiver? I have read it should be 01-07 NAV_PVT. In U-blox is this the location to send out messages?
In U-blox_congifuration_PRT(ports), What is the “Protocol out” to be sent to the GPS ZED F9P receiver? I have it as 0-UBX. In U-blox is this the location to define what protocol is sent to the GPS ZED F9P receiver?