No GPS, Here 4 GPS with CubePilot

I am using a CubePilot Orange with a Here 4 GPS with the latest firmware and DroneCAN.
I continually get ‘GPS: No GPS’ in the mission planner.
I have tried to swap the GPS out for two other Here 4 GPSes (1 Here4 Blue and 1 Here 4) with no luck and the original GPS was working fine until I messed around with the NODE ID and then it stopped working.

This is the parameters that I used in ardupilot when the GPS was working:
14-06-2024 Parameters.param (18.4 KB)

And these are the GPS parameters (I do not have the parameters from when the GPS was working):
GPS Parameters (Bad).param (1.8 KB)

Any help would be much appreciated.

Thank you


EDIT: Amended the fact I am trying to use DroneCAN
EDIT2: I have tried this now with 4 different GPSes, 3 Different Cubepilot FCs and 2 Different laptops with mission planner and I am still unable to connect to the GPS once I have changed the NODE ID for the here 4 GPS.

Hi @Finley_Redford
I tried to compare your original and bad params using lua-script.
It seem like your bad params file doesn’t contain all the params.
It’s better to save all bad params to file to do the comparison.
There are NODE ID values from original file:


Sorry for obvious point, but make sure you test your Here 4 GPS outdoor where GPS signal is stable.

Hi @postelzhuk
Thank you for your response.
I didn’t make it very clear but the ‘bad parameters’ are only the parameters for the GPS. I don’t have the original parameters from the working GPS but I don’t see any reason why these settings wouldn’t work and to the best of my knowledge the ‘bad parameter’ file has been revert to the same parameters as when the GPS was working.
I am testing the GPS outdoors.
Thank you