No contact with compass calibration on MP

After welding a bad conection between motor and esc on my Hexacopter i had to do a re instalation calibrating esc s compass …
I can`t get compass calibrating running using installation wizard what ever MP version used - tried with 3 different Pixhawk 2.4.8 and 2 different gps receivers with same result ,no contact. I can open calibration setup, get xyz axis on diagram without any dots to hit.

Have used MP 3 years first time such error occured.
When connected to my Radiolink AT 10 i get contact with 13 - 15 sattelites .Cant get green light on Pixhwk, flashing yellow .
When Calibrating Esc the system runs well and get succesful calibrating.

Does anybody have tip? I`m lost…

Frank Torvik

What brand or type of compass are you using?

Have you tested the compass outside MP to see its working fine?

is MP showing any satellite locks?

Note: In MP, Compass 2 & 3 are Internal PixHawk Compasses and Compass 1 is the external. Do you have all of them enabled?

Hi Asim. Thank you for quick response .

It must have been an error of some sort on my pc - i startet up an older pc with an old MP version

and managed to calibrate compass without any problems .

Can`t get more than 1 onboard compass and 1 external calibrated - it will do for now.

Frank :blush:

Well the goal should always be to use latest MP and latest Firmware.

bump, same/similar problem