No connection telemetry

Hello everyone,

I’m having trouble connecting to my Orange Cube on my computer via telemetry. It seems like the MAVLink communication has stopped working, even though it used to connect without any issues. When I try to connect using MAVProxy, I get the following message:

Telemetry log: mav.tlog
Waiting for heartbeat from /dev/ttyUSB0
MAV> link 1 down

Does anyone have any suggestions on how to resolve this issue? Thanks in advance!

I’m pretty new, but it could be Wiring - ensure the tx and rx pins are properly crossed.

Not likely the wiring. It’s a USB connection in the screenshot, and the claim is that it worked previously.

Will it connect via Mission Planner or QGC?

I had some trouble a while back with USB-c to USB-C; USB-A to USB-C cable worked (A port on computer), but could be my old laptop had issues. Something to try, non?

It was a wiring issue :slight_smile:

let us know what it was in particular - I’m still trying to learn this stuff. . .

I had a malfunctioning telemetry cable.

1 Like