NMEA GPS Setup Issues

I am trying to setup a HGLRC M80 which only supports the NMEA protocol and after setting the gps mode to NMEA in the parameters it says gps detected on startup and the gps appears on my transmitter through yappu telemetry, The issue is though apart from on my transmitter the gps doesn’t seem to be detected by mission planner or ardupilot. I have been messing with settings but haven’t had any luck so far, any help would be appreciated, Thank you




.

Did you solved the issue?
I also facing same issue but in the arducopter firmware with NMEA gps.
My problem is different from your scenarios because I got gos lock and getting 3dgps in mission planner ,but only issue is gps aided mode gives warning of Prearm: GPS is not healthy.

1 Like

I believe that only UBLOX GPS modules are supported in the lower flash boards like F4 racing boards, you might have to go to the custom firmware builder and select NMEA GPS to get support on your specific board.

I get the same issue like yours
Gps 3D lock, hdop 0.5, sats > 20
Hglrc m80 pro output protocol nmea
In Mission Planner gps_type : nmea
FC matek h743 wing. Did you solved the problem?