Servers by jDrones

Nimbus Tricopter VTOL

That’s normal, but I’m not sure that it’s the problem in this case as the airspeed sensor should get more accurate as the speed increases.

same with u, i think i will test it using ARSPD_FBW_MIN : 9…

I was testing my Nimbus out in the backyard in preparation for its maiden flight and everything worked except for the right tail servo. I pulled off the right v-tail section and the servo just kept spinning. I think that means the pot wiper broke so it keeps hunting.

Has anyone replaced a tail servo on the Nimbus yet?

Hello Greg,

we burned 1 ail and 2 tail servos that comes with the package from foxtech. replaced all with hitech servos.

Unfortunately 1 tail servo got burned again. We suspect that it was not freely moving that is why it got damage.

Basicaly we put the servos on the middle portion of tail body and put horn and link.

1 Like

Ok, thanks for the information, Michael.

I tried replacing the servo with an E-flite S75 which was close in size but the fit is so customized for the Emax ES08MDII Servo that I decided to order a couple of them. I’ll get my Nimbus VTOL fixed up over the weekend.

1 Like

very clean cut on the foam, nicely done.

@Graham_Dyer confirm… with change ARSPD_FBW_MIN : from 14 to 9 can fix the long transformation problem… (4 x tests today)

My new servo installed nicely and I glued the tail mount back on with Beacon Foam Tac. It was secured in place overnight using some cloth wraps.

I was not thrilled with the v-tail control surface movement when just forcing it by hand so I ended up snapping the hinge area and taping the v-shape hinge surface with 3M Blenderm tape. The tape is hard to see in the photo but has a stretching characteristic and good adhesion meant for medical use. Now the control surface is very secure and swings 45 degrees in both directions without any binding.

Time to test fly! :slight_smile:

Hello greg, we also snap the hinge and replace it with tape. there is binding on the stock design. too hard for the servos to push and pull. stress out 2 servos on this. Also with the servo horn slot. We didnt like how it gives or tranfers the servo inputs on the control flaps. we decided to make a servo link on the middle part of it. instead of using the default set up

Michael,

Thanks, it’s good to know your experience and fixes. I am reluctant to give up my quick connect feature on the tail fins but if another servo goes (and I still have a plane) then I’ll try the external linkage.

My maiden flight was mostly successful! The Nimbus VTOL hovered properly and flew around but had the same issue reported by Musa and Graham when changing to FBWA mode. It was flying but I could hear the motors throttle changing in FBWA mode like it hadn’t finished the transition. I remember throttling up but it didn’t seem to force being in full forward flight mode. After a few circuits around the field, I put it back in QSTABILIZE mode and landed perfectly.

Looking at the log, I see that my AS sensor doesn’t appear to be working. I’ll likely disable this for my next flight. The GPS speed seemed reasonable. I’m not sure what other parameter could hold up the transition.

NimbusVTOL1.param (17.0 KB)

1 Like

Here is the voltage and current graph from my maiden flight. The current was between 30 and 40 amps during take-off in QSTABILIZE mode as I ascended high enough for the first transition. In FBWA mode, it was all over the place from near 0 to 50 or 60 amps. Back in QSTABILIZE mode for landing, the current was around 24 amps as I decended and landed.

Note that the voltage never sagged using my older Multistar 6s 10AH 10C pack.

i use hinge for all join https://www.aliexpress.com/wholesale?catId=0&initiative_id=SB_20190702005750&SearchText=rc+hinge&switch_new_app=y

las time i check air speed vs ground speed gab at the first flight is around 1m/s… but after landing and take the second flight the gab increase…
so that’s why every finish flight i restart the pixhawk. but honestly i don’t know that’s helping me or not but after that the transition is going fine…
PS: i decrease my ARSPD_FBW_MIN : from 14 to 9

1 Like

two days ago i test my 16000mah battery

PS: @GregCovey i have no problem in transition to plane in this flight…

Musa,

Thanks for the information. I suspect that since my AS sensor was not working and I had ARSPD_USE set to 1 that this caused my issue. I had checked the AS sensor over the winter but maybe something changed or the pins didn’t connect properly on the nose attachment. Normally, you should have the AS sensor disabled on the first flights.

I plan to do the following things before my next flight:

  • Disable ARSPD_USE
  • Change ARSPD_FWB_MIN from 11 to 9
  • Change MIXING_GAIN from 0.8 to 0.9
  • Update from v3.9.3 to latest stable firmware v3.9.8

My firmware has not been updated for maybe 6 months so I should do an update. The plane flew on its first attempt and now I am having fun fine tuning the issues. It would be interesting to hear more from Graham about his transition issue. I believe that we have different front motor setups but I can’t fully remember.

Musa,

I just watched your video. Thanks for posting it! Watching the rear motor stop after transition on your flight reminded me to graph my rear motor. You can see on my flight below that it worked fine during QSTABILIZE modes but not during FBWA. It never shut off. My guess is that on my older firmware, there was no timeout for the “Transition to airspeed wait”. I saw some fixes for that in GitHub.

On your flight, what do you think caused the hard landing? My assumption was that this was an autonomous mission. Was the 16AH pack too heavy or do you need to change the final land speed setting? Sorry to see the damage.

I just found this new section called TECS (Total Energy Control System) in the Wiki. I don’t remember seeing these parameters last year and feel so far behind the times! :blush:

After testing my Nimbus VTOL with the AS sensor disabled, I need to fix my sensor configuration and read up on how to tune the TECs. Has anyone tuned these parameters?

Hi Greg, Musa, I followed this thread since last time. One thing that I am interested to know, to my knowledge you set Q_Assist_Speed=0 correct? What is your Auw? Do you know your stall speed? Have you tried to increase the Q_Assist_Speed to your stall speed? I also built this Nimbus style vtol but using smaller airframe: Mini Skyhunter, and I never have problem to do transition to Fbwa mode. But I always set up Q_Assist_Speed to my stall speed to avoid stall.

Servers by jDrones