Nimbus Tricopter VTOL

Yes will upload logs once i have better data signal. Great help guys.

Yesterday my Nimbus executed its first mission 100% in Auto mode. It is a very short mission, with VTOL takeoff and landing, and only 2 minutes flying as plane. It was a too windy…

Auto mode


hi guys… long time not talk here… today i test my vtol nimbus using 16000 A 25C 6S battery in auto flight… two times i flight, at the first time the plane manage to transform become plane although it’s take a long time to transform it… it seems to be too heavy and not have enough speed to transform it… and for the second flight before take off i do preflight calibration, but it’s seems can’t transform at all… so i force it to land manually… do i have to increase the ARSPD_FBW_MIN or there is another setting for it??
PS: i will upload BIN and LOG after this

here is the log and bin

do i have to adjust TRIM_AIRSPD_CM and TRIM_THROTTLE?

I have the same problem but haven’t found a solution yet. The aircraft flies too slow (on the edge of a stall) after transition and doesn’t reach full speed until later. See my post here: VTOL fails to speed up after transition?

I changed ARSPD_FBW_MIN from 11m/s to 9m/s on the last flight and on the first 2 transitions it was fine but on the second 2 it again didn’t reach full speed until after the 2nd waypoint.
Not sure about changing TRIM_AIRSPD_CM is correct - some explanation here:

hmm… do u think i causing by airspeed sensors not calibrated or something? because at my first flight yesterday it manage to complete the transition but it take until after my second way point…
after it land, i try to calibrate the airspeed sensor but, it makes fail transition at my second flight…

it’s seems GPS speed vs ARSPD sensor gap is very high after i do freflight calibration…

can we fix it by setting the ARSPD_RATIO for it?

Don’t think it’s the airspeed sensor calibration but it could be, the airspeed ratio should be automatically set with ARSPD_AUTOCAL during a loiter, so not sure what’s causing it. Seems the aircraft should reach a specified airspeed before the transition is considered complete and the motors go horizontal. It’s either not reaching this speed or not sensing that it is at that speed.

because it seems not sense the air speed right after i do preflight calibration, i do it to reduce higher airspeed sense during it still on the ground… but i think it become wrong after that…

after my first flight, the airspeed sensor read almost 9m/s during it still on the ground, after i do preflight calibration it become 2 or 3 m/s…

That’s normal, but I’m not sure that it’s the problem in this case as the airspeed sensor should get more accurate as the speed increases.

same with u, i think i will test it using ARSPD_FBW_MIN : 9…

I was testing my Nimbus out in the backyard in preparation for its maiden flight and everything worked except for the right tail servo. I pulled off the right v-tail section and the servo just kept spinning. I think that means the pot wiper broke so it keeps hunting.

Has anyone replaced a tail servo on the Nimbus yet?

Hello Greg,

we burned 1 ail and 2 tail servos that comes with the package from foxtech. replaced all with hitech servos.

Unfortunately 1 tail servo got burned again. We suspect that it was not freely moving that is why it got damage.

Basicaly we put the servos on the middle portion of tail body and put horn and link.

1 Like

Ok, thanks for the information, Michael.

I tried replacing the servo with an E-flite S75 which was close in size but the fit is so customized for the Emax ES08MDII Servo that I decided to order a couple of them. I’ll get my Nimbus VTOL fixed up over the weekend.

1 Like

very clean cut on the foam, nicely done.

@Graham_Dyer confirm… with change ARSPD_FBW_MIN : from 14 to 9 can fix the long transformation problem… (4 x tests today)

My new servo installed nicely and I glued the tail mount back on with Beacon Foam Tac. It was secured in place overnight using some cloth wraps.

I was not thrilled with the v-tail control surface movement when just forcing it by hand so I ended up snapping the hinge area and taping the v-shape hinge surface with 3M Blenderm tape. The tape is hard to see in the photo but has a stretching characteristic and good adhesion meant for medical use. Now the control surface is very secure and swings 45 degrees in both directions without any binding.

Time to test fly! :slight_smile: