Newbie with pixhawk 2.4.8

hi i m making quadcopter s500 with fc pixhawk 2.4.8 . i have faced lot of problem.
first i got readyto sky gps which was not working . then i found that the pin connection in the gps module was for ARM FC SO i changed accoding to PIXHAWK 2.4.8 connection then it worked .
2nd MOT_PWM MIN MAX alarm was getting in message SO I CHANGED the parameter list value to min =1000 and max =2000. so that alarm rectified.
2nd battery voltage below safe value . i could not rectify this alarm . i tried with various values but alarm is still their. i m using 4s 5200mah.
3RD I GOT SOLID BLUE LED INDICATION. so i checked in the ardupilot doc it says copter is armed without gps lock. so i tried to arm it without props . it works means it armed with throttle turning to right and disarmed with turning left. but when i armed with prop it goes out out control and not disarmed when turned to left. two props broke down and i have to forcefully remove battery to disarm copter it just skiding on the ground but not lifted on the ground.
am i wrong with solid blue ? or is it solid green to arm?
pl if anybody is having solution to this problem pl share with me.

Its means you put wrong sensor type data you need “analog voltage and current and choose sensor type = other”

You can set
Mot_bat_curr_max = 50
Mot_bat_volt_max = 16.8
Mot_bat_volt_min = 13.2

And you don’t care about your battery , so go to BRD and unchecked board voltage

Second thing I always 1 aux switch for copter "Arm-disarm"

May-be your props are wrong direction , atleast 2 or 3 times check motor direction with specific given motor number

Happy flying :slightly_smiling_face:

Dear Moksh patel,

Thx for the suggestion. Can U TELL me pl what that solid blue led indicate. AS i know it is for arming but no GPS LOCK .I CHECKED with this LED indication and motors were running when turned throttle turn right and disarmed when turned left. But when i tried with props the quad turned violent and gone uncontrollable.

pl tell where i m going wrong? shall i wait for solid green light for arming and disarming. At this point i have not connected external GPS. I tried it once but quad was not arming at all and motor were not spinning at all. sO I BROUGHT fresh ESC .Then anyhow all motor started spinning with esc calibration. Earlier it was total failure.

one more alarm i m getting that THROTTLE BELOW SAFE LEVEL VALUE.

PL HELP ME if u know the answer for these problem.

Once more thx for suggestion.

with reg

avinash

Moksh
Moksh Patel

    February 6

vaibhavngp:
2nd battery voltage below safe value

Its means you put wrong sensor type data you need “analog voltage and current and choose sensor type = other”

You can set
Mot_bat_curr_max = 50
Mot_bat_volt_max = 16.8
Mot_bat_volt_min = 13.2

And you don’t care about your battery , so go to BRD and unchecked board voltage

Second thing I always 1 aux switch for copter "Arm-disarm"

vaibhavngp:
skiding on the ground but not lifted on the ground.

May-be your props are wrong direction , atleast 2 or 3 times check motor direction with specific given motor number

Happy flying :slightly_smiling_face:

Firstly clear all parameters and restart Frome start again ,
1st what’s your ESC ?
2nd. your gps wire may-be rx-tx interchange so can’t work on your side
3rd 1 aux switch for arm-disarm
4th. Check out this


5th. https://ardupilot.org/copter/docs/common-vibration-damping.html (it’s very very important)
6th. Update your pixhawk to new fw like 4.0.6 i think so
7th. Choose your frame type
8th. Accelerator calibration , reboot
9th. Compass calibration , reboot
10th. Radio calibration
11th. ESC calibration (depending on your ESC)
12th. Set battery analog voltage and current --> others
13th. Notch filter (but pixhawk default pids are 9 and 10" for perfect)
14th. Autotune it’s not necessaries but fill comfortable

Bigging + advise
Disable safety switch - Brd safety switch disable

What you want from your drone ? So I will try to make batter solution for you :smile:

There is number are wrong but all are most important for beginning time

Happy flying :slightly_smiling_face:

Dear Moksh

Thx for the suggestion and advice .

I HAVE checked all the motor with motor test from mission planner (5 to 10 % throttle) as shown in right hand diagram(ABCD)

The accessaries i m using are as follows

  1. frame s500

2)esc BLHELI 30 AMP ONESHOT

  1. FC PIXHAWK 2.4.8

4)EMAX MT2216 810KV Brushless DC Motor

5)Flysky FS-i6S 2.4GHz 10CH AFHDS 2A RC Transmitter With FS-iA10B 10CH Receiver

6)4S , 5200MAH BATTERY

7)1045 PROPELLAR

pl will u check all the above combination are ok .This is my first project without any knowledge. pl feel free if i m wrong anywhere.

with reg

avinash

Ok so you need ESC calibration

Yeah everything look like ok , but don’t forget fc vibration damping pad

Please read:
https://ardupilot.org/copter/docs/initial-setup.html
https://ardupilot.org/copter/docs/flying-arducopter.html

And especially:
https://ardupilot.org/copter/docs/tuning-process-instructions.html

Dear Moksh,

THX for quick reply

i have used the dampening pad which came with pixkawk. THe pic of it i m sharing with u.

with reg

avinash

Moksh
Moksh Patel

    February 7

alt vaibhavngp:
2)esc BLHELI 30 AMP ONESHOT

Ok so you need ESC calibration

Yeah everything look like ok , but don’t forget fc vibration damping pad

(Attachment dampening.webp is missing)

Dear sir,

Thx for the information. I WILL try with the link provided.

with reg

avinash

Dear Moksh,

ONce again i m sending dampner for ur information

with reg

avinash

Dear Moksh,

THX for quick reply

i have used the dampening pad which came with pixkawk. THe pic of it i m sharing with u.

with reg

avinash

Moksh
Moksh Patel

    February 7

alt vaibhavngp:
2)esc BLHELI 30 AMP ONESHOT

Ok so you need ESC calibration

Yeah everything look like ok , but don’t forget fc vibration damping pad

Yeah you go to another way , it’s perfect :nerd_face:

Happy flying :slightly_smiling_face:

Dear MOKSH,

i have dismantled every thing and build again quadcopter. Now every thing seems to be fine. only problem i thing in my view is that motor no 4 start little bit late all other 3 motor starts at the same time . 4 no starts when slightly raised the throttle.

i have connected quadcopter with usb to mission planner and tried to arm. first it gives me alarm on HUD that “prearm throttle 2 low voltage failsafe”.

when i connect battery the message gone on HUD. Then i pressed the safety switch . long beep heard and blue light flashed and i moved throttle to right solid blue light seen and armed message was seen on HUD. I raised the throttle all motor stared with no 4 late.

after staying in this state for few seconds . i turned throttle to left and hud shows disarmed message. all these test were carried on stabilised mode only without props . alt hold not tried.

So pl just tell me can i go outside in the open ground and test the quad or anything u wished to be test before test on the ground.

with reg

avinash

Test the motor order, and after that you can fly.

Solid blue LED is armed but no GPS - you need to wait for a GPS signal or the GPS-assisted modes and Return To Launch wont work.
The best way is:
FENCE_ACTION,1
FENCE_ALT_MAX,50
FENCE_ENABLE,1
FENCE_MARGIN,5
FENCE_RADIUS,100
FENCE_TYPE,3
This way you wont be able to arm until there is a suitable 3D fix - it can take a while but is worth the wait.

Dear all,

The motor order tested with mission planner i,e A B C D as shown in Arducopter .org. document.

Secondly I have not installed GPS . THIS setup is without GPS hence solid blue light.

i will test first without GPS if everything works ok then will go far GPS . I tried with GPS but failed to arm . Hence started without GPS. Any suggestion from anybody will be welcomed. i m bit coutious since i have injured my finger during 2 nd test . .This is going to be 3rd test.

with reg

avinash

It means ESC not calibrated perfect

What happened now ?
Is not highly recommended but you can use for experiment not in professional level (may-be you can :thinking:)
Go to brd safety and disable all safety option or only check logging available so we will show your .Bin file

Is that clear ?

I would fix the GPS problem rather than disable it.

1 Like