New SDP33 Airspeed Sensor and Ardpuplane

ok, thanks. I’ll put some explanation in the code.

HI Andrew,

is there any update for the new SDP33?

Hi Everyone, sorry for the delay on this.
I’ve just pushed out plane 3.8.5beta1, which has support for the SDP33, and also supports dual airspeed sensors.
I’d really appreciate it if someone would do a flight with both a SDP33 and another airspeed sensor and send me the dataflash log so I can compare the SDP33 results with another sensor. Please also send a photo showing the physical setup of the two sensors.
You will need to set ARSPD2_TYPE=6 to enable the SDP33 as the secondary airspeed sensor. You can additionally control which i2c bus the sensor is connected to using the ARSPD2_BUS parameter (default is bus1, which is the normal “external” i2c bus).
Before you fly, make sure that if you log on the ground that you are getting logging of both sensors by looking for both ARSP and ASP2 log messages.
The 3.8.5beta1 build is building now, it should be available in an hour or so.
Cheers, Tridge


Great ! Thanks a lot.

I have just installed 3.8.5beta1 on a pixhawk 1. Everything works fine on the bench (SDP33 as single sensor and also as second sensor together with an ms5525). Test with a quickly assembled provisional “bracket”:

Unfortunately, the weather is too bad for flying today (thunderstorms and hailstorms are expected to continue until Thursday or Friday). I would like to take advantage of the bad weather and build a stable aluminum bracket on which both pitot tubes are mounted in parallel (about 2-3 cm distance) in front of the nose of the aircraft.

Regards Rolf

thanks @Rolf, looking forward to the flight log!

Measurement flight is done. Results and link to the flightlog to find there: Plane 3.8.5beta1 released

Hi, I also got two ot the SDP33 sensors and can’t get them to work. Tested it on a PH2 with AP3.8.5B1. There is no error, but also no values changing. Tried it as single sensor.

Hi David,

Is the value of ARSPD_TYPE / ARSPD2_TYPE set to 6 ? Correct ARSPD_BUS for PH2 ?

Sure. Type to 6, bus left at 1.

Other Airspeedsensors are working ? I2C SDA/SCL mismatched ?

Others are working. He recognizes the sensor somehow, because he is not giving fault message. When SDA/SLC would be crossed, he would give “bad airspeed health” I assume.

I think you use a preconfigured I2C cable with JST-GH 4 pin connectors on both sides, so you can not swap anything with that cable.

Just for information: I soldered a JST-GH to DF13 cable since i use a pixhawk 1:
1 (red) VCC +5V
2 (black) SCL +3.3
3 (black) SDA +3.3
4 (black) GND GND

I just checked the messages if you did not connect the sensors:
There is no error message ! (ArduPlane V3.8.5beta1 )

if it also does not work with PX4 stack, i would turn to drotek

Regards Rolf

1 Like

Hi Rolf,

I tested the sensor again. With AP3.8.5B1 I cant get it to work, but with PX4 1.7.4 it works! Same wiring. Tested on PH2.1

Even checked the logs and airspeed reading is always zero.

@tridge Must be some issue with the code !? Changed I2C address?
How can I help fixing this?


Hi David,

perhaps it works with the other I2C-Bus of PH2.1 ?


Just tried AP3.8.5B2 and its now working on PH1 and PH2

PH1: just set type to 6
PH2: also set BUS to 0

Benchtesting the SDP33 vs 4525

The box is for pressure distribution. Static ports are free and on the outside. tube on the left is for applying pressure.

LOG File:

SDP33 Green
4525 Red

Q: Why the steps of the green line in the last picture? Is this because of reduction of resolution for logging or does the sensor not output higher resolution?

I’ve got the latest one of these. Electronically it works, but the following pointers might help others. The 4 wires away from the sensor on mine are separated, with pin 1 marked with a grey strip. the wiring is this way: +3.3v, s london, sda, grd, with the 3.3v (or 5v, both work) on pin 1. As the sensor is sealed in, you cannot easily refer to the pcb. the i2c must be set to 100khz to run correctly, and the implementation does not ack reads so breaking some i2c scanners. (it appears on address 0x21 on mine. writing 0x21, 0x36, 0x7c (version request command) however gets acked. the ardupilot driver (when set to correct parameter, i believe 6) should then pick it up automatically and output a message during bootup.

Hopefully this should assist anyone trouble shooting this sensor, I nearly sent it back as it appeared not to work.

Great measuring device. The low resolution of the data recording at low speed I noticed too.

It does - the telemetry-datas are ok:


is there any good sensor for above 50m/s ??