New RCn_OPTION to disable RUDD_DT_GAIN please

I am using RUDD_DT_GAIN to help my large twin engine Grumman Albatross flying boat steer on the water.
I therefore also use 73/74 SERVOn_FUNCTION outputs for the left and right motors.

I use RTL and Auto modes so I have to use the 73/74 outputs rather than control the motors separately from the X9D TX, otherwise I could simply use it to do the diff throttle mixing and add a switch to turn it off after takeoff.

While in the air I want to be able to disable RUDD_DT_GAIN. I’m not comfortable allowing the inside engine to reduce RPM on landing approach. I have a tight space and am a bit terrified of a tip stall (From recent experience, balsawood + tip stall = matchwood + batteries disappearing into the depths of the lake + $1k repair bill)

It seems to me a new RCn_OPTION would be ideal for this feature. There are currently 27 values for this parameter but nothing useful for this purpose.

Correct me if I’m wrong but there doesn’t seem to be any existing way for me to achieve what I want.

Thanks in advance.

On master/latest this is possible via scripting so long as you have a flight controller with more than 1M of flash.

I’ll try that. Thanks.

Sadly, my 2017 Pixhawk 2.1 must have the known bug limiting the available flash memory. SCR_ENABLE does not appear in MP :frowning:

You might just have the wrong boot loader, try loading the full pixhawk build with the load custom firmware button

Thanks. I had already updated MP and the firmware to the latest, 4.0.5. MP is 1.3.70 build 1.3.7277.34800
I followed your suggestion and used the “load custom button” in MP and it says “No need to upload. already on the board”

But this leaves me wondering if I have the “full pixhawk build” you mentioned. The link you provided points to Pixhawk1 rather than 4. This ok ?

I downloaded the …_bl.hex file (from Pixhawk1 and 4) but the custom load button would not load either of them - unrecognized token error

what exact board do you have? A Pixhawk 2.1 is now know as Cube Black try this

BRD_TYPE = 2, so this is Pixhawk, not Cube/Pixhawk (3)

Here is the link to the product, purchased July 2017:

I don’t know how to get more information about the board. I found some instructions to use the Terminal (NSH) connection. I typed “ver all” but nothing came up. Here is the link:

"…we have discovered that early revisions of this CPU (RevA, RevY and Rev1) have a hardware problem and can actually only hold 1MB "

That’s all I could find. If could point me in the right direction to get version information from the hardware that would be great.


Oh and I tried the Cube Black firmware. Same issue.

Yeah that is just a Pixhawk1, terminal is no-longer a thing on ChibiOS. So the pixhawk one build should be correct. I would be unsurprised if that model did have the 1M limit although if that were that were the case the Pixhawk1 and Cube builds should not have flashed at all. Might be worth trying the old flash it to copter and then back to plane trick.

Ok well it was worth a try. I couldn’t even find a useful Copter version that would load.

Looks like a credit card based fix :slight_smile:

Here’s the easiest upgrade I can find:

Thanks, Bruce

Ok, like Arnie, I’m back !! Bought the mRobotics board to replace the old one, and naturally nothing fit because my old Pixhawk was a Chinese clone (Radiolink) that used some weird JST variant I thought were DF13 but aren’t and I had to attack the casing with a knife to get the new board inside.

So I’m back where I started except SCR_ENABLE is visible Yay !!!

I’ve been looking around for examples of LUA scripts that set parameter values and I can’t find anything. I simply want to test an RC input say every 2 seconds and decide based on the value whether to set parameter RUDD_DT_GAIN to either 30 or zero.

Any pointers to the correct learning materials appreciated. Thanks.