Servers by jDrones

New MP HUD I have been working on

(James Elkins) #1

Hi everyone,

I have been working on a new HUD for MP and was looking to get feedback of what I have so far…

I am using the FAA DOF (daily obstacle file) for obstacles and for live adsb data. Also created a synthetic type vision to put these on the hud. Added some touch friendly buttons for when we are using touch enabled devices. It also uses the terrain data + obstacle data to provide an elevation guide. You can tell I got a lot of my ideas from the G1000 MFD.
The HUD also displays waypoints as floating boxes in the sky… you can see in the one screenshot they are pink in color and off in the distance to the left at horizon level.

I haven’t got these changes ready for submission but eventually I plan to try to get them added to the main fork of MP.

(Gary Mortimer) #2

I will follow this with interest, particularly the ADS-B bit. We have a chain of receivers running along South Africa’s N3 highway for about 500km. If anything they show how few aircraft are equipped with ADS-B! I love your little traffic screen at the bottom left. Filtering on that would be excellent, We have to have the ability to add in whatever other electronic conspiquity method comes along, as ADS-B is well, pants :wink:

Great work well done.

( .) #3

I asked in the other thread,but i’ll ask again here.
I know these are drones and not human flown, but being that they “might” fly in commercial airspace do you intend to get this interface DO178C Level A certified as a Primary Flight Display for the operators?

If you do, I understand that MP can’t take advantage of the certification, but without question, the commit you fork back into the master could certainly be tagged “DO178C Level A certifiable”. That’s a GREAT selling point…just a thought.

There are a lot of other questions I have (as a former Airworthiness person) but i’ll restrain myself. I’m really interested whether if you’re using this for real time flight how you can make latency guarantees. I’m not being critical, if this upgrade is being developed at such high standards, it’ll be a good thing for the mission planner master branch.

(James Elkins) #4

Hi @lordneeko, not that I am ignoring you… just that I don’t know the answer for that specifically on the certification.

We use this and the old one as monitoring for auto missions and changing mission parameters on the fly. There is no latency guarantees and I don’t believe a way to make one because it’s dependant on the communication channel you use between MP and the drone. If you had it hard wired then sure… but with radio links there are going to be unseen circumstances.
I supposed you could make the guarantee that if the data arrives at MP it will be displayed one way or another :slight_smile:

( .) #5

Well it’s all about hazard and risk mitigation. If you know that you cannot have a garaunteed QoS from the connection, then you would have fail safes to back it up when you don’t have connection. But really you’re just using it for situational awareness, not flying the drone, so it isn’t important…but it also means that the FAA would prohibit flying it manually while watching this display

(TimWallace) #6

I definitely see us using this. It’s a familiar scan (using Aspen 1000 in the 172) that will help with SA as we fly in the mountains. I also really like the TCAS in the lower left as we’ve been out flying in the past and had manned traffic pop over the ridge with short notice. As a whole, what you’ve produced thus far has really got me re-thinking how we have our GCS set up and what ways we could provide information to the pilot that is more intuitive and takes less interpretation. Looks great and looking forward to seeing it develop.

(James Elkins) #7

For anyone wanting to give it a go:

(Doug Millsaps) #8

Maybe I’m doing something wrong, but I can’t get it to install correctly on Win10.

(James Elkins) #9

It’s complaining about a missing SQL library that should be in the rar file… did you extract the archive to a folder and run mission planner from that folder?

(Doug Millsaps) #10

Do the references to your Dropbox make a difference?

(James Elkins) #11

They shouldn’t, no… I will extract to a new pc when I get a chance for some testing.

(***) #12

I was able to extract and click on the mission planner app within the new folder it created on my desktop for this and the new HUD came right up. Is there a way to actually install this instead of run from the folder, is that what you are running into @TXPE

I was able to run the program once but now im getting the same error as TXPE.

( .) #13

Mission planner doesn’t “install” either in the sense you’re thinking. It just creates a shortcut to launch it. You can just right-click the exe, and click “Add Shortcut to Desktop” to install it :slight_smile:

(***) #14


I was able to launch the New_HUD MP from the folder once extracted by clicking the exe. but now it seems when I try and click it again I get the same error as TXPE.

( .) #15

This is probably something to be solved by the developer, to ensure the app is portable. @jelkins did you add custom packages to MP in order to create this version? If so, you may not have made the build process to include those packages. Which means it’ll work on your computer, but not others, unless they install that package. I’m not sure why i’m explaining this. If you wrote this MP version, you clearly know all this lol. I guess maybe i was explaining it to the others trying to use it. lol

(James Elkins) #16

Yep, have to get time to troubleshoot what is missing… obviously SQL Type appears to be missing but I have to figure out exactly what’s missing and exactly what will fix the missing dependency… probably a library install. The Sql Type should be included in the bin but that doesn’t mean all it’s required libraries got put there.
I have had others testing and have hadn’t the issue… I will look at it as soon as I get time.

( .) #17

From the link above. It’s likely that users will need to install SQLServerExpress

This issue was made worse by the fact that I first created this solution on a machine, where SQL Server was installed, so I was very much oblivious of the issue until it hit me on the face while trying to run my program on this particular machine, which did not have SQL Server

(JBREEL) #18

very easy
You have used your local PC
There are many files missing in the project.
Collect all files used and modify links
C: \ mp-1.3.55-hud

You have linked to your Derbox folder