Servers by jDrones

New FC: RadioLink Mini Pix


(Me) #82

Here are the steps to build the firmware for the Mini Pix.

  1. Get the source code.

git clone https://github.com/ArduPilot/ardupilot.git

You could also get source code via git clone https://github.com/radiolinkW/ardupilot.git but it doesn’t have the Mini Pix board build def file at this time.

I’m not sure what the other differences in the code are, I didn’t run diff on them.

Don’t download the source code via the zip file. Do a clone or a check out. You’ll see why in the next step.

  1. Update the source sub modules.

git submodule update --init --recursive

Doing a git check out or clone does not get the source code sub modules and you need them. This is the command to get them.

You’ll get a message similar to “Missing waf submodule.” if you don’t run this step.

If you get source via a zip file, git can’t do an automatic submodule update. This is why you want to do a git clone or checkout rather than the zip file.

  1. Check that the Mini Pix hardware definition file is in your source code.

ls libraries/AP_HAL_ChibiOS/hwdef/mini-pix/* Should see hwdef.dat

  1. Check that waf has what it needs to do a Mini Pix build.

./waf list_boards Should see “mini-pix” in the list.

  1. Configure the Mini Pix build.

./waf configure --board minipix

This should run to completion without errors.

  1. Get the dependencies sorted out.

I ran my build on a Fedora box. The Ardupilot Linux build page gives this file for sorting out dependencies, but it is strictly for Ubuntu systems.

Nevertheless, it provides a list of packages that are necessary to do the build. This link also has some tips.

http://ardupilot.org/dev/docs/building-setup-linux.html#building-setup-linux

My machine was already set up for Arduino development. I ran the following commands nonetheless and had no dependency issues. The second file list is for the SITL build, btw.

dnf install python-argparse openocd flex bison libncurses5-dev autoconf texinfo libftdi-dev zlib1g-dev zip genromfs python-empy cmake cmake-data

dnf install libtool libxml2-dev libxslt1-dev python-dev python-pip python-setuptools python-matplotlib python-serial python-scipy python-opencv python-numpy python-pyparsing realpath

pip2 -q install -U future lxml pymavlink MAVProxy

Not all of these are valid Fedora packages. I ignored the ones that weren’t found.

  1. Now do the actual build.

./waf plane or ./waf copter

This should run to completion.
Build Summary
Build directory: /home/me/Downloads/radiolink/ardupilot/build/mini-pix
Target Text Data BSS Total

bin/arduplane 818084 3672 127948 949704

  1. Now upload the firmare image to the Mini Pix.

I connected the Mini Pix to my computer with a USB cable. My computer has the proper USB permissions and users set up from doing other Arduino development work. I think it finds the Mini Pix on /dev/ttyUSBACM0, IIRC.

./waf copter --upload

This should run to completion without errors.

./waf plane --upload
Waf: Entering directory `/home/me/Downloads/radiolink/ardupilot/build/mini-pix’
Checking for env.py
env added CHIBIOS_FATFS_FLAG=USE_FATFS=yes
[813/815] Linking build/mini-pix/bin/arduplane
[814/815] Generating bin/arduplane.apj
githash 032b4373f68bd6b50ef1062beea8cf0dd6112ff9 md5 3b1f639d4077b891cc94267c1e3a77bd
Created /home/me/Downloads/radiolink/ardupilot/build/mini-pix/bin/arduplane.abin

[815/815] Uploading build/mini-pix/bin/arduplane.apj

WARNING: You should uninstall ModemManager as it conflicts with any non-modem serial device (like Pixhawk)

Loaded firmware for 3,0, size: 821788 bytes, waiting for the bootloader…
If the board does not respond within 1-2 seconds, unplug and re-plug the USB connector.
Found board 3,0 bootloader rev 5 on /dev/serial/by-id/usb-Radiolink_PX4_BL_FMU_v4.x_0-if00

sn: 004b00383036510534373932
chip: 10076413
family: STM32F40x
revision: 2
flash 1032192

Erase : [====================] 100.0%
Program: [====================] 100.0%
Verify : [====================] 100.0%
Rebooting.

  1. Testing.

I haven’t flown with my Mini Pix yet, but it seems to run correctly. I had no issues getting GPS lock, connecting to MissionPlanner, etc. At first glance, all the data appears to be correct. Servos seems to move as they should too.

FYI, MissionPlanner runs surprisingly well on Fedora via ‘mono MissionPlanner.exe’. No wine needed. Details here: Running Mission Planner on Linux

Special thanks to @james_pattison for answering many questions during this process.

Edit: I don’t know how to fix the bold text above.


(Ljwang1102) #83

./waf bin/arducopter --upload for copter
./waf bin/arducopter-heli --upload for helicopter


(basti) #84

thanks @linuxguy123 for this sum up! i did build and flash current arduplane 3.9.0 for mini-pix without obvious issues during the process. while everything seems to run fine, i do get occasional „no IO thread heartbeat“ messages on MP that i can‘t really valuate:

image

would very much appreciate feedback on this.

cheers, basti.


(Me) #85

I’m not an expert on Ardupilot at all, but a Google search turns up the following.

https://discuss.ardupilot.org/t/bad-logging-no-io-thread-heartbeat/14324

What SD card are you using ?


(basti) #86

yes, thanks again and sorry. after using friend google myself i could track it down to a badly formatted SD. that being said, the message persists no matter if logging is disabled unless a valid SD card is present.

cheers, basti.


(Rolf) #87

My first ChiBios flight on the MiniPix ran without any problems. Plane is a small Volantex:

Thanks for compiling @Basti
Thanks to @Tridge and everyone else who is going to replace Nutx with Chibios.

If anyone is interested, here’s the logfile:: https://www.magentacloud.de/share/9.zhmy0ok7

Regards Rolf


(basti) #88

awesome @Rolf, and thanks for linking the log.

cheers, basti.


(René) #89

Hello,
for academic work I am looking for a viable flight controller, I need it to run the official ArduPilot - ArduBoat software and APM Planner, as well as interface with a companion computer (a Raspberry Pi 3) via MavLink/CAN.
At the moment all local detailers are restocking Pixhawks, while I found a Radiolink minipx with GPS.
Does it t fulfil my requirements or should I wait for Pixhawks to be available again?
Thank you


(basti) #90

Rc output seems broken (fixed to zero) on recent commits a18758 of april 10th through 572d9ba of today.
plane version on mini-pix as well as revo-mini that is.
last working version: c311599e
can‘t see no issues filed yet though, so i‘m wondering if i‘m missing something. maybe someone can cross check?

cheers, basti.

edit: thanks @sh83 and @tridge for clarifying in chibios gitter (see PR#8171). defaulting get_max_pwm to something else than 0 brought rc output back.


(Ru-Shang Wang) #91

Thanks to linuxguy123 and james_pattison for the instructions.
Finally I was able to compile mini-pix copter code a week ago.
So far after 20+ flights things are pretty good.

I was having difficulty compiling with Windows make. Finally “cygwin + PX4 Toolchain” environment does the job.

Here are the steps:

Problems after code upload:

Radiolink advertises their altitude hold performance but after loading AC3.6RC1 the performance seems the same??


(mike kelly) #92

Rene, SInce the Radiolink mini-pix is non-standard I think you are asking for trouble if you choose this fc until it is fully integrated into Ardupilot.


(Tconners) #93

So this thread makes my head spin… I bought the mini pix for a traditional fixed wing plane.
I bought on amazon prime and should be able to return. I first loaded the radiolink MP from there site and all my controls were in mode 1… remapped them and thought hummm I should just use regular MP. Ehhhh kinda worked but just not right. I have no clue how to compile the code for airplane.
Now I learn all this and I’m just #%&%$*^
So does anyone have firmware for plane and steps for a dumbass like me on a windows box or should I just call defeat and try to return it…


(Ru-Shang Wang) #94

For Radiolink plane firmware:

If you want to build 3.6-RC1 code:

By the way, Radiolink MP is a modified version. I don’t see any problem using it.

Good luck!


(Dave) #95

I thought RadioLink took down the firmware download link for Copter and Plane some time ago. Doesn’t it have to be installed from their version of MP linking to their servers?


(Simon Cozzolino) #96

Correct, its gone. I’ve got myself a minipix and had to download their mp Here it took forever to download.

Tconners- you don’t have to compile your own or use linux or Git. Just update the firmware from their mission planner. It states plane 3.8.5 - but will flash 3.8.4 from radiolink’s own server. When I did it I had no musical tones, I actually got a failure to arm tone. Many attempts gave the same result but all is well and it works great, it just doesn’t follow all the conventions being a bit cloney. Don’t send it back! Once done use normal mission planner and don’t try and update the firmware until further notice on one of these threads.

My only complaint would be the GPS unit isn’t very good, and the baro is a tiny ic I’ve never seen before in an fc- so reliability is to be determined but it does have foam seated in a moulded recess.

All in all a bargain at £36 on banggood, accepting that there may never be any FW updates.


(peterbarker) #97

Tconners- you don¢t have to compile your own or use linux or Git. Just
update the firmware from their mission planner. It states plane 3.8.5 -

No source code has been released for their modifiations to Mission Planner
or ArduPilot, despite requests being made. That puts them in violation of
the GPLv3 license ArduPilot is released under.

All in all a bargain at £36 on banggood, accepting that there may never be
any FW updates.

You can compile and run ArduPilot from the master branch on the RadioLink
MiniPix. So while you may not see firmware updates from RadioLink, you
can get FW updates on an hour-to-hour basis from github :slight_smile:


(OldGazer) #98

And another one bites the dust.

Here’s a clue for Y’All:

If the people behind Radio Link were professionals who took real pride in their craft and who were honestly concerned about their customers having a good experience, Y’All wouldn’t be strugglin’ with this POS. Just goes to show ya that cheaper ain’t always better…

If Y’All want a smaller version of the Pixhawk, buy a PixRacer. This FC is fully supported by ArduPilot. No ghost servers, no hacked firmware forks, no hacked GCS software to deal with.


(46spikey) #99

Hi everyone.

I bought this mini pix for a plane, it was really cheap, and seems like people are OK with it… I have not flown it yet, I did however compiled Ardupilot and uploaded it. Everything was compiled, it also uploaded no problem. I put it in a plane, connected radiolink power module, gps, and all perifery, and it connected to REAL mission planner no problem. The only thing that did not work, was voltage and amp readings. I could not even change anything, mission planner said: this feature is not enabled in firmware and something about not being able to change VOLT_AMP… parameter (I forgot the name of it, sorry).
I have an original APM, pixhawk, and I have also made an Ardupilot shield for the Pizero, but I cannot figure out what to make of this lol.
The power module works, I have tested it with the original FW.
If anyone has any ideas on what to check, please… :slight_smile:
Thanks in advance.


(Marc Dornan) #100

Basically yes. Or a AUAV x2.1.


(WickedShell) #101

@46spikey if you compiled plane from master/near master, the battery param names changed slightly which is causing MP an issue. If you know the appropriate values you can set them directly from the list of all parameters.