New FC, Cube and/or Pixhawk 4, major toiletbowling on first takeoff

Frame is about a 700mm quadcopter with 17x5.5 props on 580kv motors and 35A Castle ESC’s. Power is 3S 5500mah x 3.

I have been flying this frame, motor, esc combo for years, and it works great. It uses a Pixhawk 1 and/or a Pixfalcon and flies stable with around 40 minute flight times.

We primarily do aerial mapping using Sony a5100’s and a6000’s. I am trying to swap out FC’s for newer versions for RTK gps and newer and faster hardware/firmware, but I am absolutely stuck.

I first tried a Cube and it rolls and yaws aggressively to the right until it toiletbowls a couple of times and then crashes, and I just tried a Pixhawk4 today and it still does the same thing. I have calibrated and recalibrated, changed beginning PID’s to 10hz, etc. I aggressively throttle up to get off the ground. and I know most of the tricks for trimming a large quad, double checking motor and prop config, etc,

I think it must be some default parameter that I have missed as the same thing has happened on 2 different autopilots running Copter 3.6.0. I’m sure someone will spot my problem right away as I suck at analyzing the logs.

Here are the logs from two flight attempts today. Thanks very much for the help.

Causes of toilet bowling is an uncalibratd compass. Compass readings can get messed up because of main power wires getting too close to the compass, because as more current flows throught the wire it creates electromagnetic forces causing your compass to shift around as more power is used by the motors.

Looking at the att (aka Attitude) section in your log the tune is pretty far off however there are other things that can cause this. As you can see if you graph roll and des roll they go in to completely different directions when they should closely follow each other. I’m wondering if you have done an accel calibration, so the drone knows level and Esc calibration so that the esc’s know what pwm to expect, kinda also looks like you make have some vibration issues going on so i would double check that the propellers are balanced (Cheap props are ussually a bit off if thats what you are using.) If you can post a pic of your pids? If you believe that there isn’t any issues with the stuff ive mentioned here its most likely your pids. It looks like pitch and roll need more P term and match The I term with the p term. I would set the D term at .002-.004.
Ive attached a pic of pids that i use on a drone that has 17in props with a 4s battery 320kv motors.

Thanks Jose! This is great info. Props are balanced. Frame may have vibration, but it’s an old frame and when I swap the old Pixhawk 1 back into it, it flies perfectly fine, with little to no vibration.

Would a Pixhawk 4 be more susceptible to vibration? I did mount the Pixhawk 4 on foam, whereas the older Pixhawk 1 is mounted directly to a PCB.

I noticed something strange with my transmitter, and when I took it apart I found that the throttle stick was moving outside it’s axis. So when I aggressively applied full throttle the stick wasn’t going straight up, but to the right as well. I fixed it so it stays centered. Could this have caused my problem? I did not notice it before in the RC Calibration window, but I also wasn’t applying throttle aggressively. Can you tell from the log if it received an RC input that caused it? I have another transmitter but I would hate to try it, if it’s definitely not my problem.

I will add a picture of my PID settings shortly. I set them on the low side at .1350 Rate Roll and Rate Pitch.

Thanks again for your help!

@Jose_Ortiz Here are the pids.

I haven’t used a pixhawk 4 before i think those recently came out or atleast not tooo long ago. Whats flying my big quad is a pixhawk 2 cube flight controller which has internal dampening. i also ran the auto test for your flight log and the imu was good it said so i don’t think you are having any vibration issues, ill have to take a look at the log for your RcIn Values.

So i graphed The RCIN from your log and it looks like you were trying to control the drone rather agressively, perhaps trying to correct for the behavior you were seeing. i can tell channel 3 is your throttle channel but i can’t tell what channel your roll yaw and pitch are mapped to. Have you wrote the pids from your pixhawk 1 to your pixhawk 4?

This is what i looked at ATT roll And ATT Desroll=Desired roll. Attroll is what the drone is doing and AttDesRoll is your input. Being at zero is when you aren’t putting any inputs and its just trying to hover flat. At 4800 you can see that you added some roll in to try to correct for the heavy rolling to the other side, but it looks like the drone simply isn’t pushing hard enough to correct itself because of the low pids. Again check the pids from the pixhawk1 and put them into the pixhawk 4 because the pids you showed me are the stock pids for the newer version of ardupilot 3.6.1 but the old stock pids were different if i recall correctly. If they are the same turn the pixhawk 4’s up. Mine are .1526 but it only weighs auw 1700g with really light motors. I think your pid will be in the .1500-.1600 range. Here is also a video to show you how a drone behaves when the pids are too low.

Thanks @Jose_Ortiz!

My pixhawk 1 PIDs are a bit higher.

Thanks for your help. I’ll adjust them up and try again. I thought large quads were supposed to drop the PIDs and move up.