New Build: Can't get motors to turn with Pixhawk and Bheli_S ESC's

Tattu 6S 14,000mAh Lipo
Pixhawk 2.4.8
6 Spedix IS45 Dshot Bheli_S 45A ESC’s
6 T-Motor MN4012 KV400 Motors
Flysky FS-i6 Transmitter
Flysky IA10B Receiver


I am working on a hexacopter build for a school project (specs listed above). I have downloaded Mission Planner 1.3.68 build 1.3.7105.26478 and have followed the steps on there to install Arducopter V3.6.11 onto my Pixhawk. I was able to do all the initial calibrations with the accelerometer, compass, and radio. However, when I followed the steps to do the ESC calibration: clicked “Calibrate ESC’s” with ESC type set to “Normal”, disconnect USB from pixhawk, plug in battery, push safety switch… and the Pixhawk and the ESC’s all began beeping. After this point, the throttle stick on the transmitter does not have any affect on the motors: they do not spin.

The ESC’s are plugged into the MAIN OUT pins on the Pixhawk. After doing some research, I am seeing that it may be more complicated to run use these ESC’s because they are Bheli_S and support Dshot. Is it possible to use these ESC’s and get them to work correctly? If so, can anyone walk me through the basics of what I need to do to get the motors to spin?

I discovered the “motor test” in mission planner and through that, I am able to get all of the motors to spin. I am not sure if they are configured correctly but I can control the throttle % and that seems to work.

Thank you for any and all help!

Have you reviewed this info? One point I noticed is that it states the ESCs don’t require calibration.

I did see that page but was wondering if it was specific to Bheli_32 or if it also applied to Bheli_S?

That page is the limit of my knowledge on the topic. I set up some BLHeli ESCs not long ago on a quadplane using that info. They ran a bit hot for my use so I swapped them out. Sorry I can’t help more but there are plenty of people here that know about them. They are very nice and there’s a lot of interest in them.

You can try moving the outputs to the Aux outputs (and configure the servox functions accordingly) and then set the Motor type to Dshot150. No calibration required. Note that passthru to BLHelisuite will not work with BLHeli_S firmware.

Or leave them as is and stick calibrate them the old way (All at Once)

Because I am new to all of this, I am not sure if the ESC’s are actually calibrated, but I was able to get the transmitter throttle to control the motors. I didn’t realize that in the Flight Data screen on Mission Planner, that it was giving me pre-arm errors. The RC Min was set higher than the trim for several parameters and once I fixed that, the pixhawk was able to arm and the motors spun up and react to the throttle on the transmitter. However, the sticks to pitch/roll/yaw do not seem to have any affect on the motor speeds.

Not sure what you mean by this:
However, the setting the sticks to pitch/roll/yaw do not seem to have any affect.
Affect where?

I meant that the motors should be independently rotating at different speeds with pitch/roll/yaw inputs on the transmitter.

If you are talking about running them on the bench with the props off that’s meaningless.