My under 2kg quad starts vibrating after autotunning

I am using iflight xing 2806.5 1300kv and mamba f55 esc my drone starts vibrating after i autotune the roll and pitch axis

here below i attach the log file for the same that contains logs of before and after autotune

please tell what should i do for now

also my copter is on 4.5 firmware version should it be a problem and should i downgrade to lower one

Vibrations look good.

The pitch and roll I see track with the RC inputs.

Don’t use Position hold. You’re better to use Loiter. It’s a newer mode with far more tuning options.

You should also consider

  • setting up notch filters. You will want to re-tune afterwards.
  • running MagFit on the second compass.

Read over the latest tuning guide. Follow it.

what should i do with firmware should i downgrade it or not

is there any chances of wrong setting up the pids for the controller

I don’t see a need to revert the firmware. Follow the tuning guide, set up the filters, and re-tune AS PER THE TUNING GUIDE. But in 30-40 seconds of data it looked like it was doing what it was told to do.

Any reason for running the Dev version of firmware?
You will find this in the Mega Tuning guide but:
To collect data for the notch filter which should be configured before running Auto Tune:
MOT_PWM_TYPE,6 Dshot600 is generally the most stable unless you have some reason to use 300.
Read this Setting Motor Ranges
Set these based on the hover throttle value:

No ESC telemetry? Can’t use the Bdshot version of firmware?

Then run Auto Tune again.

i dont have a bdshot esc so not using the esc telemetry

You have Dshot configured, which ESC’s do you have?

I have mamba f55 esc

Then flash the Bdshot version of firmware to the Flight Controller and configure for Bdshot.
Here if you want the stable version Orange Bdshot
Download the .apj file and flash it using Mission Planners “load custom firmware”
After fleshing the firmware configure for BDshot as per here bottom of the page Bdshot