My first FPV Plane

I have been a copter flier for a fair few years and did try Plane on an old APM board, but that was not too good.
So now with the lockdown, I decided to retry Plane fpv. So I have a mini Talon all set up with a Pixhawk 21.4.8 Chinese board, borrowed from one of my other drones. Now I am setting up for hand launch and have tested that today in Auto mode. That part looks fine, so I reckon the plane can get away with a hefty chuck. AUW is 1760gms 3lbs-14 oz, that is a fair old weight but all the videos say it will fly, all be it “Fast”
Any way my questions are

  1. Regarding Arming via Rudder, I cant get it to work. I think it may be to do with the fact the V tail surfaces only move 50% of full deflection for Rudder plus if necessary another 50% for Elevator. So as I see it the Rudder Input from tx goes from 1080-2030, but on the servo output screen the movement is very much less. So the rudder never gets to 100% right to arm. Therefore, for me it will never control arming or disarm. For now I have disabled that function
  2. Outside with the prop off, I checked manual, Autotune and FBWA, each position powered the motor. As I mentioned on Auto the motor also started with a throw. But when it came to switching into Cruise from manual, Motor stopped and control surfaces responded to tx input. Could it be the plane has to be actually flying to get Cruise and RTL to work? If so it is different to my Quad set up. I haven’t tried RTL with the tx switched off simulating a loss of signal. I was sure that previously on the APM, when rtl, or loss of tx occurred, the motor spooled up a bit and control surfaces moved to turn the plane home.
  3. OK, so I have been outside again and tested Cruise and RTL again. In Cruise, the control surfaces respond to tx input, but no motor, so I am thinking more that it is just a case the plane needs to be flying to get motor to run.
    Now with regard to RTL, I really seem to have an odd reaction. On switching to RTL, the control surfaces move to turn the plane Left, but with throttle in any position the Ailerons, and rudder element of the V tail do a dance going to full, left turn, then back to neutral almost continually. The Pixhawk still has a gps lock and has solid green light. This Dance surly has to be wrong. I next tried a tx switch off to see if RTL was actioned. The Pixhawk board changed from Green to Flashing Yellow and the control surfaces moved to a left turn, but still no motor control. I left it with no tx signal, but powered on. I then moved inside and after a few moments gps signal was lost and the motor started.
    I don’t mid trying to fly the plane in manual, but am very worried about testing RTL. As it is now, the plane will surly crash if I can’t get it back in manual quick enough. Does anyone have a view on what is correct compared to the actions my plane is doing.

Are you doing the rudder elevator mix in your radio? Because if you are just inputing raw pitch and yaw inputs to the FC and letting it take care of the V tail control outputs it shouldn’t matter what kind of setup you have. The FC will just use the yaw input from the radio for the arm signal, not the rudder output to the servo.

You can also setup arming on a switch (my preference any way).

When you’re on the ground, at or near the home point, RTL will put the controls in a bit of dance. The FC is trying to circle around the home point but between lack of movement and GPS position noise you end up with the control surfaces going into a crazy dance.

Hi, Thanks for your reply Allister. I don’t have any tx mixing, it is all done in the pixhawk. I always thought the tx rudder stick needed to be fully over “right” to arm, seems you confirm this but even setting arming check from “all” to “none” will not allow arming. Tomorrow I will try set arm by a switch to see if that works.
I follow your explanation about RTL dance, but does the motor only run if the plane is in the air and moving a minimum speed?.

Don’t fall into the trap of turning off arming checks. Leave that on. If you’re plugged into mission planner when you try to arm are you getting any warning messages?

I’m not 100% sure about the motor spinning in RTL on the ground. My gut feeling is that it doesn’t. I’d be careful testing that because if I’m wrong and that motor spins up to full speed you could have your hands full. If I get a chance to test that I will, but that probably won’t happen in the next couple of days.

Edit: Curiosity got the better of me and I had to go test it out. I was correct, the motor will not spin when armed in RTL mode when on the ground at the home location.

I have done some digging and reading and have found why the plane will not arm. It is to do with
Prearm EKF Yaw Inconsistent. There has been a lot of other users having this problem see this link
EKF2 Yaw Inconsistent and it has been going on for a year now. You can recalibrate external compass, use internal, use both compass, but the result is the same. But as one contrbutor found if you turn the plane to roughly North, the error disappears, but as yu turn from 0 degrees toward 180 degree, the error increases up to 180 degree. Then continuing around to North, the error gradually reduces bac toward zero. So this is the reason my plane will not arm via stick. I am running Plane 4.06. I see there is an update ot now to ver 4.08, but I doubt if the problem is fixed.

Just as an addon.

I changed to switch arming for the time being and that works

That seems odd to me. I would have figured if your problem was related to EKF2, then it wouldn’t matter if you used rudder or stick arming.

I wondered the same. if arming works on switch, then arming by right rudder should also work if the yaw calibration is correct, and it is. Any way at least it arms now, but looking on mission planner I notice that pre arm logs is not working. Why would I need this?, logs active on arming arm is what I would use. Perhaps this is a job for tomorrow to sort the pre arm log issue.