My Copter is not take-off

Hi, there.

I have my first drone with Pixhawk 2.1, F550 Frame set(in motor, esc…)

The motor works but does not take off.
Even if throttle is controlled to the maximum, it does not take off.

I checked props and ESC wiring.

Message doesn’t show any error(e.g. PreArm)

The below message is my copter’s output when Pixhawk connect power.
Info: APM: Copter V3.5.5 (27229c83)-?
Info: Px4: 0384802e NuttX; 1bcae90bl?
Info: Frame: HEXA??
Info: PX4v3 00270038 31365111 30313330
Info: Calibrating barometer
Info: Initialising APM
Info: Barometer calibration complete
Info: EKF2 IMU0 initial yaw alignment complete
Info: EKF2 IMU1 initial yaw alignment complete
Info: EKF2 IMU1 tilt alignment complete
Info: EKF2 IMU0 tilt alignment complete
Info: GPS 1: detected as u-blox at 115200 baud
Info: u-blox 1 HW: 00080000 SW: EXT CORE 3.01 (107900)

Could you share a video ?

1-“I checked props and ESC wiring.” I assumed prop directions are correct

http://ardupilot.org/copter/_images/MOTORS_Hexa-octo-y6.jpg

2- I assumed Autopilot and ESC connection correct

image

3-Did you perform motor test ( without propeller !! )

http://ardupilot.org/copter/docs/connect-escs-and-motors.html?highlight=motor%20test

4-What is the behaviour of the system while the throttle is at its maximum level ?

Regards
Mehmet

1 Like
  1. Props on upside down
  2. Motors spinning in the wrong direction.
  3. Aircraft is too heavy.
  4. THR_MAX does not equal 1000.


This Video is latest test yesterday.

Oh my gosh!
incorrect props directions!
The directions of DJI(is my frame maker) and Copter 3.5 are different.
Set HEXA-X and reconnect ESC to PX4.

Motor test success!
motor

Checked props and motors direction today.

I have no scale and My Copter’s real weight is unknown.
So, Upload F550 Frame Spec.

I bought F550 Set(with motor,esc and props) and don’t add other parts.
My Motor is 2212-920kv, My Bat is LiPo 6300mAh and ESC is 30A.

Where is THR_MAX param?
I don’t find it in my Mission Planner or QGC.

hi @BlueMS

The problem is still going on. You don’t have weight issue , your prop and motor are enough for your setup.

My last suggestion is perform ESC Calibration ( Pls Remove Props ) -> Link

You are right , there is no THR_MAX .

Which mode do you use when take-off transition ?

Thanks you @mehmetyldz87

Now, I know ESC Calibration, and success.
My Mode 1 is Stabilize and other Mode is Acro.

And… What’s mean “GPS: No Fix”?
I set it up Compass Calibration.

If you want to fly indoor , and you should disable the GPS .

Here ( Pls follow those steps ) -> http://ardupilot.org/copter/docs/indoor-flying.html

or

If you want to arm your copter in GPS denied enviorment for test purpose ( just for test ) , you should disable pre-arm safety check

Wow. Thank you @mehmetyldz87 !!
My copter can take-off now.

I will remember this information for later.

Have a nice day!

Great . Have Nice Flight

I dug through my parameters (AC3.5.5 on a Pixhawk) and I couldn’t find Thr_MAX… I must have been thinking about AC3.2.1 on an APM…

No GPS fix means the GPS does not have a lock on a sufficient number of satellites.

Disabling the pre-arm safety checks is just a Band-Aid, and should you set up a GPS flight mode like Loiter, or Position Hold, the quad may fly away. Also, not having a GPS fix will prevent the quad from switching to RTL should the low batter or loss of signal fail safe trigger. Food for thought.