My copter crash just after take-off


My copter Crash during take-off :

Video crash

I don’t understand what’s happen.

Here is my log :

I have calibrate esc (Racerstar RS20Ax4 V2 Blheli, configure in D-Shot by default), I have calibrate compass and accelerometre, and I have calibrate my tunigy 9xr all with mission planner.

I have verify the sense of motor (with mission planner) and the sense of propeller :

Here is the video : Test sense of motor

I have succefful manually upload arducopter 3.5.1 (with px4uploader.exe and CMD). I have take copter-3.5.1_V2 firmware (because install directly with mission planner does not work).

Any know how is wrong with my setup ?

Many thanks in advance, if i find nothink, i try to mount an old crius with multiwii for test.


I’m not an expert but from logs it appears that RCOU.C3 and RCOU.C4 are always higher at start than the others two motors.

I never use a X4 Esc, but I believe that the Esc are not calibrated properly.

I suggest to check with Blhelisuite what are the values for throttle calibration for each esc.

From the logs we can see that you gave it max throttle which should have produced a lot of thrust. You should have only given it a little throttle to get the motors spinning up.

I see that motors 1 and 2 start out higher than the others but later motor 4 goes to max but that’s not what the video shows which could me that the ESC’s are not reacting to the inputs equally. Motor numbers are not the same order as A,B,C and D in Mission Planner.

I would remove the props and put it in ESC calibration mode and see that all the motors spin up the same.

I have a similar copter with that same radio and X8R Receiver and have built 2 other units like that and have no issues with takeoffs.


Thank you for your answers.

iseries :

Motor numbers are not the same order as A,B,C and D in Mission Planner

I don’t understand.

I use this picture prop sense for detecting prop sense and this picture for detect if all esc are correctly connect to pixhawk order for connect motor

I have made a video for calibrate esc, i think all is good during calibration of my esc :
calibrate esc video

Lucamax, i have only this tool for connect to my esc with Blhelisuite :
my tool

Do you know if i connect with one of my tool to bhelisuite.

This is a picture of my esc : my esc

Thanks, nicolas.

I have calibrate esc (Racerstar RS20Ax4 V2 Blheli, configure in D-Shot by default), I have calibrate compass and accelerometre, and I have calibrate my tunigy 9xr all with mission planner.

Ardupilot doesn’t support d-shot, make sure you are in oneshot or normal pwm mode. Not saying it has anything to do with the crash, just point out to start with.

The video looks very much like either your motors are connected in the wrong order, or else you accels aren’t calibrated, or your flight controller is not in the correctly configured orientation. Is your GPS at the front of the craft, with motor #1 to the right of the gps?

About motor connections you should check , that motor A (as in order for motor connect you posted) goes to output 1 of Pixhawk, motor B goes to output 4, motor C goes to 2 and D to 3 .

With Blheli it is a good practice to use Blhelisuite to configure Esc because by default the ESC programming feature by radio is enable and that can cause some mistakes in configuration.

Try with your tool to connect with BlHelisuite , if it does not work you can use an Arduino as explained here :

From the video I can see that the motors are connected correctly and are in the correct order. The problem as I see it is they are not spinning up correctly which would indicate not calibrated correctly.

When the ESC’s are in calibration mode and you have lowered the throttle there is a beep that is heard. From there you can slowly raise the throttle and they should all spin at the same speed.

No props is recommended as it could fly off during calibration.


Fnoop, yes, motor #1 is to the right of the gps and my gps is at the front of my quadri.

I try to connect to my esc with my ftdi but it doesn’t work. Have an idea where i buy a cheap and easy programer for connect to my ESC ?

I think my problem is because my ESC is program for d-shot and pixhawk does not support this…


I have buy a Skyline32 Mini Flight Controller card on hobbyking for managing my racerstar esc.

I come here when i configure my esc with oneshot125 and configure pixhawk in oneshot125.

Thanks all.


I don’t understand one thinks, if my esc is not compatible with pixhawk, normally, I should not arrived to calbrate my esc …

This would mean that’s the problem not come from my ESC …

Any idea about this ?


Calibration has nothing to do with compability.
You can perfectly calibrate an Esc , this means seittng the minimun e maximum values for throttle signal coming from receiver and have totally wrong Esc parameters for the motor you are using or for your flight control.

As suggested use an Arduino to connect to your esc and make the setup with blhelisuite.

I have an RS20A 4-in-1 working with a PixRacer running ArduCopter 3.5. I had to set the esc’s up via a programmer (I used an old Naze32 and the BLHeli chrome app). MissionPlanner calibration didn’t seem to work for them.

OK, good news, now I now that I must attempt my new card for program manually my ESC. Nicolas.

nico38, you are welcome !

hi, I use blheli 4in1 configured in standard mode in MP, no specific firmware, works perfectly with my Pixracer.

And esc calibration works with mission planner ?

After reset pixhawk and recalibrat all, my pixhawk fly well for 2 or 3 minutes. after crash.

I post log here, can you give me whats happen :

another log with another flight with lipo at full power :

Many thanks, i don’t know in what direction i must go ;(


It seems like a radio calibration problem. Just try with a radio calibration at mission planner.


you know that if you pull the throttle to zero in stabilize mode it stops controlling the attitude and will crash?
Maybe you should start with AltHold mode.