mRo X2.1-777 issue with bar: "Check BRD_TYPE: Baro: unable to initialise"


one of my copters which did not have any issues for at least 10 hours of flight time suddenly does not want to initialize any more. There seems to be an issue with the barometer, I get the messsage:

“Check BRD_TYPE: Baro: unable to initialise”

I did not change anythink before it happend. It just came out of nowhere. I also tried to flash Arduplane and then Arducopter again to try a new.

I have seen similar problems connected to low quality controllers, but mine is a mRo X2.1-777, so I still hope it is not defective?

I had same issue on CUAV V5+ FC …

Which firmware version are you running?
Did you try a full parameter reset

I’m running 4.0.7, previously without problems. I did try to make a full parameter reset by flashing Arduplane on the FC.

And, did you have to trash it?


  • Running on battery power instead of USB
  • Set BRD_TYPE to 20

Otherwise it may well be a damaged barometer. There’s a similar thread from a Pixhawk 4 user: Pixhawk 4 - Check BRD_TYPE: Baro: unable to initialise driver

1 Like

Just check BRD_TYPE parameter…, in case the board is defective and under warranty contact mRo… they will find the right solution

1 Like

Thank you, I have tried all the things described above and I guess the barometer is defective.

Any ideas what will happen if this happens inflight?

well… flight can be unstable and the behavior it’s like stabilize

1 Like

Ok, so no rocket launch or similar stuff. That is ok.