mRo Sik v2 connecting to Matek H743

Hi all. I just received my new mRo Sik v2 telemetry set. No instructions, but I did find barebones guide online. Two quick questions:

  1. Can/should these radios be firmware updated?

  2. Are the CTS and RTS connections to the Matek necessary, or just V, G, Tx and Rx?


  1. They are most likely at the latest firmware.
  2. Not required

Thank you, Dave. Follow up, how does one check the FW version, in Mission Planner?

Allan-Here is a good guide on how to view the firmware on the radios:
Sik Radios Mp

Perfect! It looks great. Thanks for the link!

Ok, my bad, I set up the SiK radios and they actually worked with minimal fussing, until I made the mistake of pushing the “Upload Firmware on Local” button in Mission Planner, which I think flashed the ground radio but not the air radio. Now the radios won’t communicate.

I assume I need to connect the air radio to MP to update it’s FW, but the air unit has no USB connector. How does one do this? P.S. I called mRobotics for help but no reply yet.

Now you’ve done it!

Power up the craft with the battery. In Mission Planner select the Com port the ground radio is on and 57.6 baud but DO NOT CONNECT. Press the Load Settings button from the Sik Radio Screen and hopefully both sides will populate. Post a screen shot of that so we can see what you have flashed.

Right! Stupid me…comes with everyone saying “use the latest FW!!!”. Not in this case. Did what you said, but info only comes up on one side of the SiK Radio screen. Will try to send pics.

Both radios don’t have a USB port? I thought all V2 versions did.

No, unfortunately, the mRo air unit only has a JST-GH connector.

In the past I have used an FTDI adapter to update those radios w/o a USB port. Do you happen to recall what firmware version was on there before you updated to V2.2? Kind of surprised Mro did not have V2.2 on it already as that version came out a year ago.

Yes, I think I’ll either buy or make a connector. FW version that came on the radios was SiK 2.2, which seems the same after the update, so I don’t understand what changed.

Should I use a USB adapter to plug the air unit into the computer to flash it in MP? Is that the most logical remedy?

None of my mRo air radios have USB ports. They are my preferred brand, but that’s the down side.

@Awsmits, use an FTDI adapter. They are a dime a dozen on Amazon, Adafruit, Sparkfun, Mouser, DigiKey, etc.

However, I don’t think firmware is your problem. Check this out:

I just did EXACTLY what you did with a set of mRo radios. I updated the ground radio to v2.2 using Mission Planner’s local update feature, and it immediately reconnected to the air unit that was still running v2.0.

This post also discusses mixing firmware versions without significant issue.

I will update the air radio later, anyway. I’ll let you know how that goes.

I just updated two mRo air radios via FTDI adapter in 3v3 mode. The RTS/CTS lines need not be connected for programming. It worked exactly like updating the ground radio.

Just tried the radios again, making sure everything was connected correctly. In MP, still only loads data on the Local side. Green LED on the ground radio is flashing slowly, green LED on air radio also flashing slowly, but red LED also blinking twice, then repeats. Even tried it on a different PC.

Not sure what else to try, except flash the air radio and hope that works, but not likely based on Yuri’s info. What else might be at issue?

It’s possible that the firmware update changed some settings, but your screen shows what I think are all defaults, so that seems unlikely.

Flashing green indicates searching, so it’s clear the radios are not talking to one another.