MP install problems with W7 Pro X64, not able to make it work?

Hello out there… I know this topic has been posted before but I am still not able to install MP on my PC.
I have tried to download Net framework upgrade to 4.6.2 from even this is a problem. The download just seems to sit in “limbo” and never finishes.

Thoughts anyone?

I went from version 4 :

Then upgraded, but it’s been a while sine I did that.

Thanks Joe,
I know just enough about computers to be really dangerous. I am also a New Bee to the Drone
world. Double set back for me. I did get MP on my PC, but I am not able to connect Via WiFi
On the home screen of MP, after log in to the SV. The connection window pops up, but all it say’s
is “Mavlink connection” No file transfer. Any thoughts? My wifi window shows the SV is connected,
then if you cancel out of it, the window shows “lost connection” I also pulled the power to my home router,
thinking it was interfering with the connection. Any help would be great!


What are you trying to connect to with wifi? Mission Planner connects commonly to a Pixhawk via a USB serial port. There are some multirotors that use a wifi connection for control and they would have a specific port they were designed to connect to from Mission Planner.

So I think you need to be a little more specific about what you are trying to do before anyone can help.

Hey Mike,
I have a Skyviper 2450gps, it does not have a USB port. As I explained this my first Drone and I am very new to all of this. Just looking for a little help to get going. I have MP installed now on my W7Pro laptop, and my Mac book pro as well, but still no success in connecting with my SV 2450.

take a look at that