Moving from quad to hexacopter...problem with firmware


I desperatelly need help here…I had Pixhawk 2.4.8 based quadcopter and recently buy two more motors, esc’s, frame…and so on…to build hexacopter. Quad works fine, but when I upload new firmware from Mission planner (4.0.2) my drone won’t arm.

Everything else seems to be OK…I can connect Pixhawk to Mission planner…but it shows only 4 motors in Motor test. Not sure what to upload which can be useful to resolve my prob…

I’m sending some screenshots and video:!AoXovnN-smCh8EmwqfJ4Q7aVgR5c?e=zYeHvp


1 Like

Have you gone through all the mandatory parameters in the setup menu?

Yup…I’ve just gone through all Initial setup…everything seems to be set. What I’ve notice is that GPS doesn’t work and also Battery level shows 0 V…even I have plugin the battery…

Do you see 6 motors in the motor test tab? As for the battery level do you have the parameters set up in the battery monitor window? You’ll have to check to make sure the serial port you have the GPS plugged into is set up properly.

Your FRAME_CLASS parameter is set to 0 (undefined). Change it to 2 for Hexa and reboot the board. You have no motors assigned to outputs now (the SERVOx_FUNCTION parameters.

Nope…there are motors from A to D (only 4 motors). I’ve setup battery. I’m not sure whare to setup serial port for GPS. :frowning:

THAAANKS! I have noticed that yesterday but forgot to check today :slight_smile:
Now, just need to set my GPS…it still doesn’t work…Parameter list.param (18.1 KB)

Set your serial protocol for the port you have the GPS connected to 5. That should get it working.

Hey Voisar…hm, how can I figure out which port use my GPS…right now I see that two serial ports are set for GPS…Serial port 3 and 4:

Which port is it plugged into on your Pixhawk 2.4.8?

It was pluged in to GPS port as it was before, when I had quadcopter…that’s why I was confused when you asked me :), see pic:

Sorry, I’m not the expert :frowning:

According to this the gps port is serial 2. Try setting serial2 to option 5 and see if that fixes your issue.

Is it mather if other two Serial ports are set to 5 also…and would I loose some settings if I change serial 2 from 1 to 5?

I open that link you have post…It sais that GPS is Serial port 3:

But eather way, nothing changes :frowning:

Oh you’re right I was looking at it upside down. At this point I’m not sure what to tell you. It looks like your settings are correct, and if it worked previously I don’t know why GPS would stop working.

Ok, thanks a lot for your time and effort…I’ll figure out somehow :slight_smile:

The GPS port you are connected to is Serial 3. 1&2 are the telemetry ports.

Yup…I have figure out, but nothing was changed if I set this port to 5…it still doesn’t work. There has to be something else…thanks!

I’m an idiot…what can I say…simply, it wasn’t able to get satelites in the room (even it was near to window). Previously, it just had satelites in his memory and it get them easily after restart…but now, after new firmware and my reset of pixhawk, it just erase his memory…

I just take it to the balcony and wait for couple of min… :slight_smile:

Thanks guys for helping me, I appreciate!

1 Like


Serial 0 is USB (serial protocol 2 (MavLink 2), 115200 baud)
Serial 1 is Telem1 (serial protocol 1 (MavLink 1, 57600 baud)
Serial 2 is Telem2 (serial protocol 1 (MavLink 1, 57600 baud)
Serial 3 is GPS (serial protocol 5 (GPS), 38400 baud)
Serial 4/5 are “Open”.

I use Serial 1 for 915mHz telemetry and OSD.
I use Serial 2 for a STorM32 gimbal controller
I use Serial 3 for GPS.
I use Serial 4 for FrSky S.Port passthrough (OpenTX) (serial protocol 10, 57600 baud) for telemetry to my Taranis X9E.

1 Like